none
Erro ao instalar solução pelo power shell. RRS feed

  • Pergunta

  • Olá a todos do fórum.

    Estou com um problema em um sharepoint foundation 2010 quando tento fazer o deploy de uma solução(Timer Job) usando o power shell. Para explicar o erro, vou descrever os passos usados para fazer o deploy.

    No shell de gerenciamento do SharePoint 2010 digito os seguintes comandos:

    1) Add-SPSolution -LiteralPath 'caminho_da_solução\timerjob.wsp'

    2) Install-SPSolution –Identity timerjob.wsp -GACDeployment

    No power shell não informa nenhum erro após digitar esses comandos, no entanto, quando eu verifico na administração central/configurações do sistema/gerenciar soluções do farm/, a minha solução timerjob.wsp fica com uma mensagem eterna de implantando.

    Segui os passos para forçar a execução o trabalho que implementa soluções no link abaixo:

    http://social.msdn.microsoft.com/Forums/pt-BR/f897f82c-505b-4c8c-adb5-c9ac9901f168/erro-na-implantaoremoo-de-uma-soluo

    mas não resolveu o problema.

    Alguém tem ideia do que pode estar acontecendo?

    Sobre o ambiente que estou tentando publicar a solução, o que posso dizer a mais, é que ele foi migrado do sp2007 para o sp2010.

    Aguardo qualquer dica sobre como resolver o problema.

    Att.:
    Santiago Silva


    quinta-feira, 20 de junho de 2013 21:28

Todas as Respostas

  • Ola SAntiago,

    Voce deve ter um problema nos jobs de SharePoint, mais concretamente nos servicos "Windows SharePoint Services Timer" ou "Windows SharePoint Services Administration" verifique se estao em started status. 

    Execute o seguinte comando e devera finalizar a instalacao correctamente "stsadm -o execadmsvcjobs".


    André Lage Microsoft SharePoint, CRM Consultant
    Blog:http://aaclage.blogspot.com
    Codeplex:http://spupload.codeplex.com/http://simplecamlsearch.codeplex.com/

    sexta-feira, 21 de junho de 2013 14:36
    Moderador
  • Obrigado pela dica André, mas infelizmente já tentei este procedimento sem sucesso. Quando eu tento executa-lo me retorna a seguinte mensagem de erro:

    "O serviço de administração está em execução, portanto, todos os trabalhos de administração serão executados no serviço de timer."

    A forma que consegui executar o comando, foi parando o serviço SharePoint Central Administration. Entretanto quando eu verifico o status da solução pela própria administração central, continua com a mesma mensagem "Implementando".

    Não sei como proceder diante desse erro. Se tiver mais alguma hipótese para o erro...

    De qualquer forma agradeço a ajuda.

    att.:
    Santiago Silva


    sexta-feira, 21 de junho de 2013 17:48