none
SoundPlayer não executa no servidor RRS feed

  • Pergunta

  • Bom Dia Amigos.

    Estou com um probleminha,tenho o seguinte código

            private void playSound()
            {
                SoundPlayer player = new SoundPlayer();
                player.Stream = Sconto.Properties.Resources.huga2;
                player.Load();
                player.Play();
            }
    

    O Qual eu chamo dentro de um Item.DataBound

            protected void rptNovosPedidos_ItemDataBound(object sender, RepeaterItemEventArgs e)
            {
                try
                {
                    if (e.Item.ItemType == ListItemType.AlternatingItem || e.Item.ItemType == ListItemType.Item)
                    {
                        playSound();
                        DeliveryPedido pedido = (DeliveryPedido)e.Item.DataItem;
                        PopulaItensGrid(((Label)e.Item.FindControl("lblNumeroItens")), ((Label)e.Item.FindControl("lblTempo")), pedido, ((Label)e.Item.FindControl("lblNomeCliente")), ((Label)e.Item.FindControl("lblTelefone")));
                    }
                }
                catch (Exception ex)
                {
    
                    Response.Write(@"<script language='javascript'>alert('O seguinte erro ocorreu: \n" + ex.Message + ex.Source + " .');</script>");
                }
            }

    Localmente está funcionando perfeitamente, porem quando publico para o servidor o mesmo não funciona, o audio que estou utilizando tem a extensão .wav

    Alguem saberia me informar o que pode estár ocorrendo?

    Obrigado!


    "Nunca deixe que os outros te subestimen, mas tambem não seja arrogante seja humilde e prove quem é

    quinta-feira, 5 de dezembro de 2013 13:44

Todas as Respostas

  • Cara isso ai é WEB né...

    O audio está saindo na máquina servidora, a máquina que você publicou o WebSite...

    Pra sair na máquina cliente ou utilize algum Plugin ou a TAG <AUDIO> do HTML5...


    Leonardo Lourenço Silva


    sábado, 28 de dezembro de 2013 13:13