none
Entity Framework não cria o banco de dados no SQL Server Management 2012, em vez disso ele cria somente no (localdb)\v11.0. Como resolver esse problema? RRS feed

  • Pergunta

  • Eu sou iniciante em Entity Framework e estou tendo alguns problemas.

    Eu crio as minhas entidades e dou SaveChanges() de boa.

    Então,se eu tento conectar com o banco de dados através do Server Explorer,e se eu tento conectar com a Instancia do SQL Server 2012 que no meu caso é (PC-PAULO\INSTANCIA-PJ), o banco de dados criado pelo Entity não aparece como opção MAS se eu utilizo como instancia (localdb)\v11.0, o banco de dados criado pelo Entity aparece como opção na tela.

    Como resolver este problema?

    Como fazer com que o Entity em vez de salvar no (localdb)\v11.0 salvar no SQL Server?

    Muito Obrigado :D 

    • Movido Roberto F Fonseca segunda-feira, 5 de janeiro de 2015 01:38 Movido para um forum mais adequado
    domingo, 4 de janeiro de 2015 21:28

Todas as Respostas

  • Olá Paulo,

     isso depende de sua connection string ! Para qual banco de dados sua connection string aponta ?

    segunda-feira, 5 de janeiro de 2015 11:26
  • Olá meu amigo. Eu já tentei configurar minha Connection String no App.config mas não está dando certo.

    Deveria apontar para = PC-PAULO/(localdb)\v11.0

    Como eu resolvo isso? Como configurar corretamente a Connection String? Entity Framework 6 e Visual Studio 2013. 

    App.config(padrão)

    <?xml version="1.0" encoding="utf-8"?>
    <configuration>
      <configSections>
        <section name="entityFramework" type="System.Data.Entity.Internal.ConfigFile.EntityFrameworkSection, EntityFramework, Version=6.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089" requirePermission="false" />
      </configSections>
      <entityFramework>
        <defaultConnectionFactory type="System.Data.Entity.Infrastructure.LocalDbConnectionFactory, EntityFramework">
          <parameters>
            <parameter value="v11.0" />
          </parameters>
        </defaultConnectionFactory>
        <providers>
          <provider invariantName="System.Data.SqlClient" type="System.Data.Entity.SqlServer.SqlProviderServices, EntityFramework.SqlServer" />
        </providers>
      </entityFramework>
    </configuration>

    Muito obrigado :D

    terça-feira, 6 de janeiro de 2015 20:11
  • OLá Paulo,

     veja como ficaria seu AppConfig :

    <?xml version="1.0" encoding="utf-8"?>
    <configuration>
      <configSections>
        <!-- For more information on Entity Framework configuration, visit http://go.microsoft.com/fwlink/?LinkID=237468 -->
        <section name="entityFramework" type="System.Data.Entity.Internal.ConfigFile.EntityFrameworkSection, EntityFramework, Version=6.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089" requirePermission="false" />
      </configSections>
      <connectionStrings>
        <add name="Daniel" connectionString="Data Source=SEUSERVER;Initial Catalog=SEUBANCO;Persist Security Info=True;User ID=sa;Password=suasenha;MultipleActiveResultSets=True"
          providerName="System.Data.SqlClient" />
      </connectionStrings>
      <entityFramework>
        <defaultConnectionFactory type="System.Data.Entity.Infrastructure.SqlConnectionFactory, EntityFramework" />
        <providers>
          <provider invariantName="System.Data.SqlClient" type="System.Data.Entity.SqlServer.SqlProviderServices, EntityFramework.SqlServer" />
        </providers>
      </entityFramework>
    </configuration>
     Lembrando que pode utilizar também a sobrecarga do construtor da classe DbContext passando a connectionstring !

    • Sugerido como Resposta Daniel Brito br quarta-feira, 7 de janeiro de 2015 11:30
    quarta-feira, 7 de janeiro de 2015 11:30