locked
Procv pegar o maior valor RRS feed

  • Pergunta

  • Olá,

    Tenho a seguinte situação: tenho uma tabela que tem vários códigos, sendo que muitos deles iguais. Não posso retirá-los. Nesses códigos constam valores. Quero que o Procv na hora que eu procurar um valor que seja um desses "repetidos" ele me dê o que tem o valor maior.

    Exemplo

    Código

    Valor

    03.001.001-1

      R$                     4,00

    01.005.001-0

      R$                     9,00

    01.005.001-0

      R$                    10,00

    13.370.015-0

      R$                     36,25

    01.005.001-0

      R$                   152,00

    04.005.123-1

      R$                   246,00

    01.005.001-0

      R$                   354,00

    06.001.245-0

      R$                   550,00

    01.005.001-0

      R$                   684,00

    04.005.123-1

      R$                1.578,00


    Os valores em vermelho são os "repetidos". No caso acima eu preciso que ele na fórmula me dê o valor R$ 684,00.

    Tem como?
    sexta-feira, 16 de outubro de 2009 13:36

Todas as Respostas

  • Sim primeiro voce utilize a formula Cont.se e depois realize a fórmula Máximo, após isso você poderá utilizar a formula PROCV,

     

    Abraços,


    Baldini Fabio
    • Sugerido como Resposta Baldini domingo, 23 de maio de 2010 15:17
    domingo, 23 de maio de 2010 15:17
  • Supondo que os seus dados esteja distribuídos no intervalo A1:B10, a fórmula a seguir deve solucionar a tua questão:

    =SOMARPRODUTO(MÁXIMO((CONT.SE($A$1:$A$10;$A$1:$A$10)=

    MÁXIMO(CONT.SE($A$1:$A$10;$A$1:$A$10)))*($B$1:$B$10)))

    [ ]s


    Adilson Soledade - MOS http://adilsonsoledade.blogspot.com/
    • Sugerido como Resposta adilsonsoledade segunda-feira, 24 de maio de 2010 02:42
    segunda-feira, 24 de maio de 2010 02:42
  • Boa tarde AdilsonSoledade

    Desculpe eu me meter, mas eu também estou aprendendo e usei a tua fórmula mas ela deu o valor máximo do intervalo A1:A10 (R$ 1578,00) e o Angelo estava querendo obter o maior valor entre os valores que tem o número do código em vermelho (01.005.001-0), ou seja R$ 684,00.

    Eu fiquei curioso querendo saber a fórmula.

    Obrigado

    quinta-feira, 3 de junho de 2010 17:18
  • Me parece q a melhor solução seria:

    =SOMARPRODUTO(MÁXIMO(($A$1:$A$10=C2)*($B$1:$B$10)))

    Onde na célula C2 seria inserido o código procurado.

    domingo, 6 de junho de 2010 08:33