none
Banco de Dados não carrega dados no ReportView RRS feed

  • Pergunta

  • Ola, poderia me ajudar estou tentando carregar dados no reportview porem aparece o erro "AN ERROR OCCURREND DURING LOCAL REPORT PROCESSING".  

    Agora não sei se tem algo no lugar errado ou se esta faltando algo

    Segue o codigo:

      OleDbCommand cmd = new OleDbCommand();
                OleDbDataAdapter da = new OleDbDataAdapter();
                DataSet ds = new DataSet();
                DataTable dt = new DataTable();
                string strReport = "";
    
                try
                {
                    strReport = @"Report1.rdlc";
                    reportViewer1.LocalReport.ReportPath = strReport;
                    OleDbConnection conn = new OleDbConnection(Properties.Settings.Default.BDConnectionString);
                    conn.Open();
                    cmd.Connection = conn;
                    cmd.CommandText = "SELECT POPID, Posto, Componente, DescricaoDesvio, DataDesvio, Modelo FROM DataCarrier";
                    cmd.CommandType = CommandType.Text;
    
                    OleDbDataReader DR = cmd.ExecuteReader();
                    dt.Load(DR);
                    ReportDataSource RDS = new ReportDataSource("DataSet1", dt);
    
                    ReportParameter p = new ReportParameter();
                    reportViewer1.LocalReport.SetParameters(new ReportParameter[] { p });
    
                    reportViewer1.Clear();
                    reportViewer1.LocalReport.DataSources[0] = RDS;
                    //this.reportViewer1.RefreshReport();
    
                    reportViewer1.SetDisplayMode(DisplayMode.PrintLayout);
                    reportViewer1.ZoomMode = ZoomMode.PageWidth;
                    this.reportViewer1.RefreshReport();
    
    
                }
                catch (Exception ex)
                {
                    MessageBox.Show(ex.Message);
                }

    domingo, 14 de fevereiro de 2016 18:13

Respostas

Todas as Respostas

  • Bom dia Willians Fernando,

    Esta mensagem de erro está completa ou tem algo mais além disso?

    Atenciosamente


    Marcos SJ

    Esse conteúdo e fornecido sem garantias de qualquer tipo, seja expressa ou implícita

    MSDN Community Support

    Por favor, lembre-se de Marcar como Resposta as postagens que resolveram o seu problema. Essa é uma maneira comum de reconhecer aqueles que o ajudaram e fazer com que seja mais fácil para os outros visitantes encontrarem a resolução mais tarde.

    segunda-feira, 15 de fevereiro de 2016 11:00
  • Problema resolvido. Obrigado
    • Marcado como Resposta Marcos SJ segunda-feira, 15 de fevereiro de 2016 13:17
    segunda-feira, 15 de fevereiro de 2016 12:11
  • Olá Willians Fernando,

    Poderia compartilhar com a comunidade o que fez para resolver o problema?

    Atenciosamente


    Marcos SJ

    Esse conteúdo e fornecido sem garantias de qualquer tipo, seja expressa ou implícita

    MSDN Community Support

    Por favor, lembre-se de Marcar como Resposta as postagens que resolveram o seu problema. Essa é uma maneira comum de reconhecer aqueles que o ajudaram e fazer com que seja mais fácil para os outros visitantes encontrarem a resolução mais tarde.

    segunda-feira, 15 de fevereiro de 2016 13:17