none
Debugar Projeto em ASP.NET RRS feed

  • Pergunta

  • Ola Amigos

    Eu sempre "Debuguei" meus projetos, dai tive problemas com o VS 2005 e tive que reinstala-lo.
    O problema e que agora nao consigo mais "Debugar" o sistema em ASP.NET claro.

    Com o F11 e possivel executar linha a linha a ver o que acontece com cada variavel.

    Existe algum parametro para ativar/desativar o debug.


    Obrigado e um Abraço
    terça-feira, 18 de agosto de 2009 18:32

Todas as Respostas

  • VENTANA,

    Segue link de ajuda:

    How To: Enable Debugging for ASP.NET
    http://msdn.microsoft.com/en-us/library/e8z01xdh%28VS.80%29.aspx

    Att.

    Ari C. Raimundo
    terça-feira, 18 de agosto de 2009 19:27
  • Ventana, no web.config da seu site tem uma opção la chamada <compilation debug> ela tem que estar setada como TRUE para funcionar.

    Ex: <compilation debug="true">

    Att,

    Israel Gonçalves “Caso esta resposta tenha ajudado a solucionar sua dúvida, favor clicar em “Marcar como Resposta” para beneficiar outros membros da comunidade que estejam lendo este thread”.
    terça-feira, 18 de agosto de 2009 20:06
  • Muito obrigado por sua ajuda amigos


    Israel

    Essa linha ja consta no meu web.config.
    <compilation debug="true">



    Ari C. Raimundo

    Segui o exemplo do link que voce me enviou e da para percerber que a execucao da pagina esta em modo Debug, pois agora o botao "Stop Debugging" esta habilitado, para para de Debugar.

    Entretanto nao esta debugando, pois as pausas que coloquei, estao sendo desprezadas e a execucao do sistema nao esta parando neles.

    E agora?


    Obrigado e um Abraço
    quarta-feira, 19 de agosto de 2009 13:49
  • Ventana, vc ja verificou as configurações de DEBUG no seu VS ? em Tools -> Opions -> Debugging -> General. Verifique o Debug esta habilidato...


    Att,

    Israel Gonçalves “Caso esta resposta tenha ajudado a solucionar sua dúvida, favor clicar em “Marcar como Resposta” para beneficiar outros membros da comunidade que estejam lendo este thread”.
    quarta-feira, 19 de agosto de 2009 13:59
  • Bem, pelo que percebi parece que todas as opcoes de Debugging, estao habilitadas.
    Pore, o problema continua.

    E falando em problemas, tudo isso comecou depois que eu formatei a maquina e instalei tudo de novo e agora quando eu executo a pagina, mais problemas.

    Antigamente quando eu mandava executar, a pagina era aberta e se eu executasse novamente, a novo pagina era aberta sobre a janela ja aberta.Agora quando executo e aberta primeiro uma pagina em branco e depois a janela do sistema e se eu executar novamente e aberta uma nova pagina em branco e uma segunda janela do sistema, ou seja, a cada execucao  aberta uma nova pagina.


    E agora?

    Obrigado e um Abraço
    quarta-feira, 19 de agosto de 2009 19:05
  • Ventana,

    A recomentação da Microsoft é o KB abaixo:

    Visual Studio .NET Debugger Does Not Stop on Breakpoints When You Debug ASP.NET Pages
    http://support.microsoft.com/kb/306169/EN-US/

    Tente também fazer o que esse link sugere:

    Breakpoint not hooked up when debugging in VS.Net 2005
    http://stackoverflow.com/questions/163133/breakpoint-not-hooked-up-when-debugging-in-vsnet-2005

    Att.

    Ari C. Raimundo
    quarta-feira, 19 de agosto de 2009 20:45
  • Muito obrigado Ari, darei uma olhada.


    Um Abraço
    quarta-feira, 19 de agosto de 2009 20:58
  • Ventana, esse aconteceu comigo ontem, depois que formatei minha maquina. O erro era o Internet Explorer 8, tem que habiliar a depuração de códigos em Ferramentas -> Opções -> Navegação, existe uma opção de DESABILITAR DEPURAÇÃO, deixe essa opção desmarcada...

    Comigo funcionou...

    Valew
    Israel Gonçalves “Caso esta resposta tenha ajudado a solucionar sua dúvida, favor clicar em “Marcar como Resposta” para beneficiar outros membros da comunidade que estejam lendo este thread”.
    quinta-feira, 20 de agosto de 2009 13:54
  • Obrigado pela dica Israel

    Eu torci para que fosse esse o meu problema mas infelizmente nao funcionou.

    Como disse antes auqle botao para interromper o debug "Stop debugging", sequer fica habilitado, mesmo se eu começar a executar o projeto com o F11.

    Uso o VS 2005.Baixe o VWD 2005 e tambem nao funcionou, entao baixei o VWD 2008 e ai sim funcionou,Porem eu nao gosto muito de utiliza-lo, digamos que nao me sinto a vontade com ele.

    No momento irei depurar dessa forma, ficando com o VS 2005 e o VWD 2008 abertos.Desenvolvo no VS e quando precisar depurar, uso o VWD.

    Ainda continuarei tentando descobrir o que aconteceu.


    Obrigado e um Abraço
    quinta-feira, 20 de agosto de 2009 14:14