none
Exibir imagem em datalist. RRS feed

  • Pergunta

  • Tenho um datalist que é preenchido via código. Esse datalist tem uma imagem cujo UrlImage recebe o caminho da imagem que está gravado na banco de dados. Só que na hora da execução a imagem aparece em branco. Alguém pode por favor me ajudar? Segue o codigo abaixo. Detalhe: o caminho gravado na banco está certo.
                        <asp:DataList ID="DataList1" runat="server" BackColor="White" BorderColor="#CCCCCC" BorderStyle="None"  BorderWidth="1px" CellPadding="4" ForeColor="Black" GridLines="Horizontal" Width="100%">
                            <FooterStyle BackColor="#CCCC99" ForeColor="Black" />
                            <HeaderStyle BackColor="#333333" Font-Bold="True" ForeColor="White" />
                            <ItemTemplate>
                                <asp:Image ID="Image1" runat="server" CssClass="img_clientes" 
                                    ImageUrl='<%# eval("imagem") %>' 
                                    style="left: 0px; top: 0px; width: 115px; height: 74px" />
                                <asp:Label ID="Label1" runat="server" Text='<%# eval("nome") %>' Font-Names="Arial Black" Font-Size="12pt" ForeColor="Black"></asp:Label>
                                  &nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;
                                <asp:Label ID="Label2" runat="server" Font-Names="Arial" Font-Size="11pt" ForeColor="#3333FF" Text='<%# eval("cidade") %>'></asp:Label>
                                <br />
                                <br />
                                <asp:HyperLink ID="HyperLink1" runat="server" CssClass="link_clique_aqui" NavigateUrl='<%# eval("site") %>' Text='<%# eval("site") %>' Target="_blank"></asp:HyperLink>
                                <br />
                            </ItemTemplate>
                            <SelectedItemStyle BackColor="#CC3333" Font-Bold="True" ForeColor="White" />
                        </asp:DataList>


    • Editado DecoRosa segunda-feira, 5 de novembro de 2012 23:05
    • Movido Levi DomingosModerator terça-feira, 6 de novembro de 2012 14:26 (De:VB.NET e Visual Basic)
    segunda-feira, 5 de novembro de 2012 18:32

Respostas

  • Resolvido!

    Na verdade todo o problema era por causa da pasta onde as imagens eram salvas que não tinha permissão de leitura!

    • Marcado como Resposta DecoRosa terça-feira, 11 de dezembro de 2012 13:10
    terça-feira, 11 de dezembro de 2012 13:10

Todas as Respostas

  • Bom dia, com o inspetor de código do browser o caminho que é mostrado está correto? tem com postar aqui o que o browser está mostrando?

    Rodrigo Reis Ferreira
    Microsoft Certified

    segunda-feira, 12 de novembro de 2012 11:26
  • Resolvido!

    Na verdade todo o problema era por causa da pasta onde as imagens eram salvas que não tinha permissão de leitura!

    • Marcado como Resposta DecoRosa terça-feira, 11 de dezembro de 2012 13:10
    terça-feira, 11 de dezembro de 2012 13:10