none
Erro envio e NF-e RRS feed

  • Pergunta

  • Pessoal, preciso de uma ajuda com este erro abaixo, acontece no momento de enviar a Nf para a SEFAZ, fica com o staus de aguardando envio e o trabalho de lotes retorna este erro:

    A seqüência de caracteres de data/hora UTC não estava no formato esperado.

    quinta-feira, 20 de janeiro de 2011 15:42

Todas as Respostas

  • Rafael, boa tarde.

    O problema cima está no webservice de Retorno da transmissão da NF.

    Existe uma tag no XML chamada <dhRecbto> - responsável por retornar a data/hora em que foi recebida a sua transmissão - que está passando uma data no formato inválido para conversão. O método ::parse() da classe DateTimeUtil, converte uma string em uma data no formato UTCDateTime (yyyy-mm-ddThh:mm:ss). Apesar do formato estar de acordo com o especificado pelo método, a informação contida está vindo incorreta, por exemplo "0110-21-21T15:22:15", entendeu?

    Para resolver o problema, você tem duas soluções:

    1. Caso sua localidade permita utilizar webservices de outro Estado, procure utilizar a de SP, que está funcionando;
    2. Fazer um tratamento de erro sobre a função em questão nos objetos que processam as informações de retorno como a classe EFDocMsgFormat_XmlSubmitReturnV2_BR, método read(), linha 43:

     dateTime = DateTimeUtil::parse(returnDateTime);

    Para qualquer uma das soluções acima, superando esta mensagem provavelmente você terá outro problema: Sua NF será rejeitada sob o código 411: “Campo versaoDados inexistente no elemento nfeCabecMsg do SOAP Header”

    Para resolver esse outro problema, veja esse link: http://social.msdn.microsoft.com/Forums/pt-BR/dynamicsaxpt/thread/a4128acb-817d-4215-aa96-99d877a1452e

    Espero ter ajudado.

    Abs.

    • Sugerido como Resposta Edvandro Santos quinta-feira, 27 de janeiro de 2011 17:06
    quinta-feira, 20 de janeiro de 2011 17:05
  • Olá Evandro,

    Ajudou sim, fiz estas mudanças e o envio funcionou. Obrigado !!!!

     Em um outro post vi uma correção que você fez em relação ao erro de rejeição 508, onde o CNPJ do Destinatario fia em branco no xml de envio. teria como me mandar esta correção?

    obrigado,

     

    Rafael

     

    quinta-feira, 27 de janeiro de 2011 12:55
  • Rafael, bom dia.

    Fico feliz em poder te ajudar! :) Com relação ao seu outro problema, a MS liberou um KB pra resolver esse problema. Segue link pra download:

    https://mbs2.microsoft.com/Knowledgebase/kbdisplay.aspx?wtntzsmnwukntmmyxpvsklryklwntmmrrsolsnmumztltrtk

    Abraços

    quinta-feira, 27 de janeiro de 2011 13:54
  • Olá Evandro,

     

    Resolvi modificando o tipo de endereço do cliente para a opção "Entrega", no cadastro do cliente.

    Obrigado pelo apoio,

     

    Rafael

    quinta-feira, 27 de janeiro de 2011 15:46
  • Rafael, boa tarde. Eu é quem agradeço à possibilidade de poder te ajudar.

    Abraços.

    quinta-feira, 27 de janeiro de 2011 17:06