none
Erro ao tentar publicar uma entidade ou excluir atributos RRS feed

  • Pergunta

  • Olá,

    Estamos tendo um problema quando tentamos publicar uma entidade que sofreu alguma personalização ou excluir algum atributo.

    Ao tentar executar qualquer dessas funções é mostrada uma janela de erro com o seguinte texto:

    "Erro.

    Tente esta ação novamente. se o problema persistirm consulte a comunidade Microsoft Dynamics CRM para obter soluções e

    contate o administrador d Microsoft Dynamics CRM na organização. Finalmente você pode cotatar  Suporte Microsoft."

    Esse erro começou a acontecer após a criação de um atributo na entidade ocorrência (incident)  do tipo datetime, depois não consegui mais publicar esse entidade nem excluir esse campo.

     

     

     

    terça-feira, 14 de setembro de 2010 02:54

Respostas

  • Boa Tarde,

    Este problema já ocorreu comigo uma vez, no meu caso o problema foi quanto aos relacionamentos existentes nesta entidade que eu tentava importar.

    Para resolver meu problema verifiquei todas as entidades relacionadas à Entidade que apresentava o problema, importei primeiramente todas as Entidades relacionadas,  publiquei as alterações e depois importei a com problema, desta forma funcionou no meu caso.

    Acredito que o que esta ocorrendo no seu CRM possa ser o mesmo problema.

    Outra dica é verificar os logs de Erro do IIS no event viewer do Windows, pois quando existe um campo com problemas o IIS registra no log.

    Abraço.

     


    Eduardo Santos
    • Marcado como Resposta Wagner D. Mattos terça-feira, 14 de setembro de 2010 16:26
    terça-feira, 14 de setembro de 2010 15:23

Todas as Respostas

  • Olá,

     

    Pegue um exportação da entidade, limpa ou  algum backup e tente importar por cima.

     

    Abraço,

     


    Ricardo Alves
    www.ricardoalves.me
    • Sugerido como Resposta RicardoAlves terça-feira, 14 de setembro de 2010 16:24
    terça-feira, 14 de setembro de 2010 02:59
  • Ricardo,

    Tentei fazer isso mas não dá certo. As personalizações continuam, apesar da importação da entidade "original" não ter apresentado erros.

    terça-feira, 14 de setembro de 2010 03:31
  • Fiz o processo  de "voltar" a para a configuração original de outras duas entidades (contas e contatos) e para estas agora funciona a publicação. Somente para ocorrências é que o problema continua.

    Na personalização do formulário de ocorrencia, é mostrado o original, mas os atributos ainda aparecem os personalizados que criamos.

    terça-feira, 14 de setembro de 2010 10:08
  • Está correto... pois a importação é acumulativa e não exclui atributos....

     

    Agora você vai ter que criar os atributos com outro nome.

     

    Abraço,

     


    Ricardo Alves
    www.ricardoalves.me
    • Sugerido como Resposta RicardoAlves terça-feira, 14 de setembro de 2010 16:24
    terça-feira, 14 de setembro de 2010 10:30
  • Boa Tarde,

    Este problema já ocorreu comigo uma vez, no meu caso o problema foi quanto aos relacionamentos existentes nesta entidade que eu tentava importar.

    Para resolver meu problema verifiquei todas as entidades relacionadas à Entidade que apresentava o problema, importei primeiramente todas as Entidades relacionadas,  publiquei as alterações e depois importei a com problema, desta forma funcionou no meu caso.

    Acredito que o que esta ocorrendo no seu CRM possa ser o mesmo problema.

    Outra dica é verificar os logs de Erro do IIS no event viewer do Windows, pois quando existe um campo com problemas o IIS registra no log.

    Abraço.

     


    Eduardo Santos
    • Marcado como Resposta Wagner D. Mattos terça-feira, 14 de setembro de 2010 16:26
    terça-feira, 14 de setembro de 2010 15:23
  • Ricardo, obrigado pela informação. Mas ainda assim não consigo excluir esses atributos. Estava pensando que a causa poderia ser o que o Eduardo comentou, algum relacionamento com alguma outra entidade que não foi importado. Vou rever todas as dependências da entidade e seguir nessa linha. Acredito que seja o mesmo problema pelo qual o Eduardo passou.

    Muito obrigado!

    terça-feira, 14 de setembro de 2010 16:29
  • Eduardo,

    O problema era esse mesmo. Haviam 4 entidades com relacionamentos com a ocorrência que não havia importado. Assim que elas foram incluidas, tudo voltou a funcionar.

    Muito obrigado!

    terça-feira, 14 de setembro de 2010 17:25