none
não estou conseguindo publicar meu site no IIS Local RRS feed

  • Pergunta

  • Olá,

    Criei uma aplicação em asp.net mvc 5 com .Net Framework 4.5, publiquei ela no IIS 8 da minha máquina para testa-la antes de subir para o servidor da LocalWeb... Publiquei como release dentro do c:/inetpub/wwwroot/meuSite, criei o pool do aplicativo setando a versão do .Net para 4.0, adicionei o site na porta 80, dei permissão no diretório para o grupo IIS_IUSRS tudo normal, mas quando eu dou um search pra rodar meu site no browser, aparece o diretório com pasta bin, as views, o web.config e não carrega minha página...

    Eu não tenho marter Page, e também não precisei setar uma start page, quando compilo pelo VS ele acessa a minha homePage (Index) normal, não manjo muito de MVC mas estou apreendendo...

    Tenho uma classe "RouteConfig.cs" que acredito ser a responsável por isso:

     public class RouteConfig
        {
            public static void RegisterRoutes(RouteCollection routes)
            {
                routes.IgnoreRoute("{resource}.axd/{*pathInfo}");

                routes.MapRoute(
                    name: "Default",
                    url: "{controller}/{action}/{id}",
                    defaults: new { controller = "Home", action = "Index", id = UrlParameter.Optional }
                );
            }
        }

    essa classe de alguma forma é chamada quando a minha solution é iniciada, acredito que talvez pelo Global.asax...

    Mas enfim rs, o problema é que eu gostaria de acessar meu site no IIS da mesma forma que eu consigo pelo VS, podem me dar uma dica?

    Obrigado!

    terça-feira, 1 de dezembro de 2015 01:33

Respostas

  • Olá,

    Coloca os arquivos na pasta wwwroot e acessa via localhost. Ou converta sua pasta meusite para aplicativo no iis, e acessa localhost/meusite que deve funcionar. Quando instalou iis, marcar pra instalar o asp.net 4.0,4.5



    terça-feira, 1 de dezembro de 2015 11:42
    Moderador
  • show de bola! muito obrigado! adicionei a versão 4.5 no IIS! Problema resolvido.

    • Marcado como Resposta Sestari terça-feira, 1 de dezembro de 2015 17:10
    terça-feira, 1 de dezembro de 2015 17:10

Todas as Respostas

  • Olá,

    Coloca os arquivos na pasta wwwroot e acessa via localhost. Ou converta sua pasta meusite para aplicativo no iis, e acessa localhost/meusite que deve funcionar. Quando instalou iis, marcar pra instalar o asp.net 4.0,4.5



    terça-feira, 1 de dezembro de 2015 11:42
    Moderador
  • show de bola! muito obrigado! adicionei a versão 4.5 no IIS! Problema resolvido.

    • Marcado como Resposta Sestari terça-feira, 1 de dezembro de 2015 17:10
    terça-feira, 1 de dezembro de 2015 17:10
  • já fiz tudo isto e nada

    já publiquei via ftp em um servidor externo e não reconhece a página

    sábado, 8 de setembro de 2018 22:19