none
Simplificar formula matricial RRS feed

  • Pergunta

  • alguem pode me ajudar a simplificar a formula abaixo, para que não seja necessário repeti-la 12 vezes, é que tenho uma planilha de vendas na média com 15000 linhas uma para cada mes, e queria fazer uma tela de resumo, onde o usuario selecionaria o mes em uma celula , e  assim a formula realizaria a soma dos dados da planilha do mes solicitado.

    a formula

    =SE($C$1="JAN";SOMARPRODUTO(((JAN!$B$10:$B$37=$C$2)*(JAN!$C$10:$C$37=$C$3)*(JAN!$D$10:$D$37=$C$4))*(JAN!$E$10:$E$37));SE($C$1="FEV";SOMARPRODUTO(((FEV!$B$10:$B$37=$C$2)*(FEV!$C$10:$C$37=$C$3)*(FEV!$D$10:$D$37=$C$4))*(FEV!$E$10:$E$37));0))

    domingo, 25 de abril de 2010 15:24

Respostas

  • Experimente desta forma aqui:

     

    =SOMARPRODUTO(

    (INDIRETO($C$1&"!$B$10:$B$37")=$C$2)*

    (INDIRETO($C$1&"!$C$10:$C$37")=$C$3)*

    (INDIRETO($C$1&"!$D$10:$D$37")=$C$4)*

    (INDIRETO($C$1&"!$E$10:$E$37")

    )

     

    [ ]s


    Adilson Soledade - MOS http://adilsonsoledade.blogspot.com/
    segunda-feira, 26 de abril de 2010 01:22

Todas as Respostas

  • Experimente desta forma aqui:

     

    =SOMARPRODUTO(

    (INDIRETO($C$1&"!$B$10:$B$37")=$C$2)*

    (INDIRETO($C$1&"!$C$10:$C$37")=$C$3)*

    (INDIRETO($C$1&"!$D$10:$D$37")=$C$4)*

    (INDIRETO($C$1&"!$E$10:$E$37")

    )

     

    [ ]s


    Adilson Soledade - MOS http://adilsonsoledade.blogspot.com/
    segunda-feira, 26 de abril de 2010 01:22
  • funcinou, perfeitamente desta forma

    =SOMARPRODUTO(

    (INDIRETO($C$1&"!$B$10:$B$37",1)=$C$2)*

    (INDIRETO($C$1&"!$C$10:$C$37",1)=$C$3)*

    (INDIRETO($C$1&"!$D$10:$D$37",1)=$C$4)*

    (INDIRETO($C$1&"!$E$10:$E$37",1)

    )

    segunda-feira, 3 de maio de 2010 03:38