none
Provider: Interfaces de Rede SQL, error: 26 - Erro ao Localizar Servidor / Instância Especificado RRS feed

  • Pergunta

  • Oi Pessoal,

    Hospedei uma simples aplicação no Hotel da Web, plano para sqlserver, porem não consigo configurar corretamente o webconf e ocorre o erro "Provider: Interfaces de Rede SQL, error: 26 - Erro ao Localizar Servidor / Instância Especificado". Os formulario foram construido arrastando o grid e ligando aos datasources, sem nehuma linha de código. Entrei em contato com o hotel da web e eles responderam (Pedimos a gentileza que nos informe qual a funcionalidade que o senhor deseja realizar, pois caso seja "Procedure", "Trigger" ou "view", informamos que não são funcionais no servidor, pedimos a gentileza que verifique utilizando outras funcionalidades).

    Existem algum ponto em que estou pecando na configuração?

    Um abraço a todos..

    <?xml version="1.0"?>
    <configuration>
       <connectionStrings>
          <add name="ApplicationServices" connectionString="data source=.\SQLEXPRESS;Integrated Security=SSPI;AttachDBFilename=|DataDirectory|\aspnetdb.mdf;
             User Instance=true" providerName="System.Data.SqlClient" />

          <add name="ArtmaqDBConnectionString" connectionString="Data Source=.\SQLEXPRESS;AttachDbFilename=|DataDirectory|\ArtmaqDB.mdf;Integrated
            Security=True;Connect Timeout=30;User Instance=True" providerName="System.Data.SqlClient" />
       </connectionStrings>
     <system.web>
      <authorization>
       <allow roles="administrador" />
      </authorization>
      <compilation debug="true" targetFramework="4.0">
       <assemblies>
        <add assembly="System.Design, Version=4.0.0.0, Culture=neutral, PublicKeyToken=B03F5F7F11D50A3A"/>
        <add assembly="System.Web.Extensions.Design, Version=4.0.0.0, Culture=neutral, PublicKeyToken=31BF3856AD364E35"/>
        <add assembly="System.Windows.Forms, Version=4.0.0.0, Culture=neutral, PublicKeyToken=B77A5C561934E089"/>
                          </assemblies>
       </compilation>
       <authentication mode="Forms">
         <forms loginUrl="~/Account/Login.aspx" timeout="2880" />
       </authentication>
      <membership>
       <providers>
        <clear/>
        <add name="AspNetSqlMembershipProvider" type="System.Web.Security.SqlMembershipProvider"
                                        connectionStringName="ApplicationServices" enablePasswordRetrieval="false"
                                        enablePasswordReset="true" requiresQuestionAndAnswer="false" requiresUniqueEmail="false"
                                        maxInvalidPasswordAttempts="5" minRequiredPasswordLength="6" minRequiredNonalphanumericCharacters="0"
                                    passwordAttemptWindow="10" applicationName="/"/>
       </providers>
      </membership>
      <profile>
       <providers>
        <clear/>
        <add name="AspNetSqlProfileProvider" type="System.Web.Profile.SqlProfileProvider"
                                       connectionStringName="ApplicationServices" applicationName="/"/>
       </providers>
      </profile>
      <roleManager enabled="true">
       <providers>
        <clear/>
        <add connectionStringName="ApplicationServices" applicationName="/"
                                        name="AspNetSqlRoleProvider" type="System.Web.Security.SqlRoleProvider"/>
        <add applicationName="/" name="AspNetWindowsTokenRoleProvider"
                                      type="System.Web.Security.WindowsTokenRoleProvider"/>
       </providers>
      </roleManager>
       <customErrors mode="Off"/>
        </system.web>
      <system.webServer>
      <modules runAllManagedModulesForAllRequests="true"/>
     </system.webServer>
    </configuration>

    quinta-feira, 11 de outubro de 2012 13:33

Respostas

  • Seu problema deve estar aqui

     <add name="ApplicationServices" connectionString="data source=.\SQLEXPRESS;Integrated Security=SSPI;AttachDBFilename=|DataDirectory|\aspnetdb.mdf;
             User Instance=true" providerName="System.Data.SqlClient" />
    
          <add name="ArtmaqDBConnectionString" connectionString="Data Source=.\SQLEXPRESS;AttachDbFilename=|DataDirectory|\ArtmaqDB.mdf;Integrated 
            Security=True;Connect Timeout=30;User Instance=True" providerName="System.Data.SqlClient" />
       </connectionStrings>

    veja com eles como vc tem que fazer a autenticação.


    Não esqueça de usar o componente </> na barra para posta seu código. Microsoft MCPD,MCTS,MCC

    quinta-feira, 11 de outubro de 2012 14:03
    Moderador