none
Excel utilizando 100% da CPU RRS feed

  • Pergunta

  • Utilizo o Office 2016 H&B e ele para de responder utilizando funções simples como, por exemplo, SOMASE.

    Tenho 111 linhas de uma coluna com a função SOMASE.

    Tentei utiliza-la em mais colunas totalizando 30, quantidade de dias do mês, mas ficou impossível de utilizar pois demora muito para processar.

    A função busca as informações em outra planilha que contém a base de dados a ser somado.

    Como ficou quase impossível o uso da formula em todas as colunas, foi criada uma Macro para copiar a formula da primeira coluna, colar na coluna seguinte, copiar resultado e colar somente valores.

    Dessa forma ficou menos ruim com uma média de 7 minutos para atualizar, quando não trava e tenho que fechar o Excel.

    Isso é erro no Excel ou a aplicação é limitada para determinadas funções?

    Segue função:

    =SOMASE([Consolidado_Vendas_Setembro.xlsx]Setembro!$E:$E;$A108&$C108&Q$2&$A$1&Q$1;[Consolidado_Vendas_Setembro.xlsx]Setembro!$Q:$Q)

    Segue Macro:

    Sub ColarFórmulas()
    '
    ' ColarFórmulas Macro
    '

    '
        Range("F4:X2221").Select
        Selection.Copy
        Range("Y4:AQ2221").Select
        Selection.PasteSpecial Paste:=xlPasteFormulas, Operation:=xlNone, _
            SkipBlanks:=False, Transpose:=False
        Application.CutCopyMode = False
        Selection.Copy
        Selection.PasteSpecial Paste:=xlPasteValues, Operation:=xlNone, SkipBlanks _
            :=False, Transpose:=False

         Range("F4:X2221").Select
        Selection.Copy
        Range("AR4:BJ2221").Select
        Selection.PasteSpecial Paste:=xlPasteFormulas, Operation:=xlNone, _
            SkipBlanks:=False, Transpose:=False
        Application.CutCopyMode = False
        Selection.Copy
        Selection.PasteSpecial Paste:=xlPasteValues, Operation:=xlNone, SkipBlanks _
            :=False, Transpose:=False

    ...

    Até finalizar em
    ...

                       Range("F4:X2221").Select
        Selection.Copy
        Range("VD4:VV2221").Select
        Selection.PasteSpecial Paste:=xlPasteFormulas, Operation:=xlNone, _
            SkipBlanks:=False, Transpose:=False
        Application.CutCopyMode = False
        Selection.Copy
        Selection.PasteSpecial Paste:=xlPasteValues, Operation:=xlNone, SkipBlanks _
            :=False, Transpose:=False
            
        
        Range("A2:A3").Select

    End Sub

    ImagemImagem

    sexta-feira, 21 de outubro de 2016 11:49

Todas as Respostas

  • Usar 100% da CPU não é algo anormal. No entnato, gastar 7 minutos para fazer algumas fórmulas está esquisito.

    Se você possui fórmulas que referencia outra pasta de trabalho (arquivo), terá uma lentidão anormal a não ser que abra a pasta de trabalho alvo em questão, infelizmente.

    Quando você abre a pasta de trabalho externa, o tempo de cálculo reduz?


    http://www.ambienteoffice.com.br - http://www.clarian.com.br

    sexta-feira, 21 de outubro de 2016 18:47
    Moderador