none
IFrame dentro de um modal RRS feed

  • Pergunta

  • Tenho esse código, uma função asp:

    sub montaContrato()
        %>
        <!--<div id="dialog1" title="Diálogo Modal" hidden="hidden">Este é um teste de Dialogo Modal usando JQuery-UI</div>-->
        <iframe id="dialog" class="ui-helper-hidden"></iframe>
        <tr>
            <td class="label_right" nowrap>Contrato&nbsp;</td>
            <td>
                <input type="text" name="num_contrato" value="" size="15" maxlength="17" tabindex="1" OnKeyPress="javascript:MascAlfaNum()" OnKeyDown="TeclaEnter()" onchange="PesquisaContratoMontaFilial();">
                <!--<img id='' style='display:; cursor:hand' name='Pesquisa_Contrato' width='16' height='16' src='/gen/mid/lupa.gif' border='0' alt='Pesquisa Contrato' onClick="javascript:AbrePesquisa('/GEN/ASP/GEN0001a.asp?ind_situacao=&tipo_empresa=&ind_classificacao=&p_cod_tipo_contrato=&indsubmit=false&txt_nome_campo_cod=num_contrato&txt_nome_campo_cod_ts=cod_ts_contrato&txt_nome_campo_desc=nome_contrato&ind_tipo_pessoa=J&funcao_executar=PesquisaContratoMontaFilial();&abre_modal=S&ind_alteracao_contrato=&tipo_preco=','Pesquisa_Contrato','Pesquisa Contrato', 700, 500, 20, 15, 'S')">-->
                <img id='btnLupa' style='display:; cursor:hand' name='Pesquisa_Contrato' width='16' height='16' src='/gen/mid/lupa.gif' border='0' alt='Pesquisa Contrato' onclick='AbrirModal("http://www.javascriptkit.com", "Javascript Kit", 480, 360)'>
                <input type="text"  name="nome_contrato" value="" size="50" tabindex="-1" Readonly class="camposblocks">
                <input type="hidden" name="cod_ts_contrato" value="">
                <input type="hidden" name="ind_tipo_pessoa" value="J" />
            </td>
        </tr>    
        <%
    end sub 

    Esse código é montado nessa <table>:

    <body>
    <%AbreTable()%>
    <font class="subtitulos"><%=txt_subtitulo%></font>
    <%FechaTable()%>
    <form method="post" name="form01">    
    <%AbreTable()%>
    <div id="txt_msg" class="msg" align="center"><%=txt_msg%></div>
    
    
    <table border="0" width="100%">
        <%
        montaOpSucInspetoria()
        montaContrato()
        if txt_modulo = "40" then
            montaNumBeneficiario()
        end if 
        montaNumAtendimento("S")           
        montaDataAtendimento()
        montaUsuarioAtendimento()
        montaCboMotivoAtd()
        montaCboSituacao()
        %>
    </table>

    A função montaContrato() é que monta essa <tr>. O que está acontecendo. Na chamada do botão btnLupa, que é uma imagem(gif), se eu coloco nessa chamada uma URL do tipo: http://www.minha_pagina.com.br, funciona muito bem. Porem se eu coloco uma página que está no diretório do projeto, na forma passada acima /GEN/ASP/GEN0001a.asp?..., não funciona. Gostaria de saber se alguém pode me dar uma luz a respeito.


    • Editado pnet quarta-feira, 5 de agosto de 2015 16:42
    quarta-feira, 5 de agosto de 2015 15:56

Respostas

  • Funcionou assim. Tive que chamar outra página, assim:

    ../../ace/ace005a.asp?/GEN/ASP/GEN0001a.asp$$ind_situacao=&tipo_empresa=&ind_classificacao=&p_cod_tipo_contrato=&indsubmit=false&txt_nome_campo_cod=num_contrato&txt_nome_campo_cod_ts=cod_ts_contrato&txt_nome_campo_desc=nome_contrato&ind_tipo_pessoa=J&funcao_executar=PesquisaContratoMontaFilial();&abre_modal=S&ind_alteracao_contrato=&tipo_preco=", "Pesquisa Contrato", 700, 500

    • Marcado como Resposta pnet quarta-feira, 5 de agosto de 2015 18:59
    quarta-feira, 5 de agosto de 2015 18:59