none
Sobre AJAX! RRS feed

  • Pergunta

  • eu queo instalar o AJAX no visual studio 2008 mas até agora não consegui.

    Fui no site da Microsoft e baixei esses trÊs downloads:

    Ajax control toolkit.
    Ajax library.
    Aspnet Ajax Preview.

    fui ainda no baixaki e baixei um execuátvel ASPAJAXExtSetup

    Só consegui instalar o executável. Fui na quia criar novo web site e não tinha nenhum projeto de asp net com ajax. 

    Alguém ai pode me ajudar pra saber o que baixar e o que instalar pra fazer funcionar o ajax. 

    Um abraço!!

    """Disse Jesus: Eu Sou o Caminho e a Verdade e a Vida; ninguém vem ao Pai senão por mim. Jo14:6.Procure uma igreja evangelica e entregue sua vida a JESUS e o deixe salvá-la!!!"""

     

    quinta-feira, 22 de outubro de 2009 13:49

Respostas

  • Bom dia !

    Qual erro ocorreu quando você tentou inserir o ScriptManager no Default ?
    No VS2008 não aparece o  "ASP.NET AJAX-Enable Web Site" pois como o AJAX está embarcado não é necessário um template como nas versões anteriores do visual studio.



    “Caso esta resposta tenha ajudado a solucionar sua dúvida, favor clicar em “Marcar como Resposta” para beneficiar outros membros da comunidade que estejam lendo este thread”.
    Atenciosamente,
    Harley Araujo
    • Sugerido como Resposta Harley Araujo segunda-feira, 26 de outubro de 2009 10:29
    • Marcado como Resposta Eujobi segunda-feira, 26 de outubro de 2009 14:08
    segunda-feira, 26 de outubro de 2009 10:29

Todas as Respostas

  • Bom dia,


               Você não precisa se preocupar com isso porque no 2008 o AJAX já vem como padrão.
               Pode iniciar o seu projeto que as funcionalidades já estarão disponíveis automaticamente.

               Somente adicione os componentes do ToolKit conforme o exemplo:
               http://forum.imasters.uol.com.br/index.php?/topic/330158-instalando-o-ajax-control-toolkit-no-visual-studio-2008/ 
    • Sugerido como Resposta Harley Araujo segunda-feira, 26 de outubro de 2009 10:29
    quinta-feira, 22 de outubro de 2009 13:53
  • Olá Kauebranco
    Obrigado pela ajuda. 
    O toolkit já tá tudocerto.
    Mas ainda estou confuso. Quando crio um site web a pagina defaut.aspx não vem com scriptManager então eu arastei pra página mas deu problema. Não quiz compilar. Apesar da webconfig estar com o Ajax. Eu então adicionei uma masterpege e arrastei o scriptmanger e deu certo. Não entendi porque com a defaut.aspx não deu. 

    Na minha guia de criar o projeto não tem nenhum projeto "ASP.NET AJAX-Enable Web Site", mas apenas "ASP.NET Web Site" O certo não era ter? 

    Um abraço!!!!

    """Disse Jesus: Eu Sou o Caminho e a Verdade e a Vida; ninguém vem ao Pai senão por mim. Jo14:6.Procure uma igreja evangelica e entregue sua vida a JESUS e o deixe salvá-la!!!"""  
    sexta-feira, 23 de outubro de 2009 10:39
  • Bom dia !

    Qual erro ocorreu quando você tentou inserir o ScriptManager no Default ?
    No VS2008 não aparece o  "ASP.NET AJAX-Enable Web Site" pois como o AJAX está embarcado não é necessário um template como nas versões anteriores do visual studio.



    “Caso esta resposta tenha ajudado a solucionar sua dúvida, favor clicar em “Marcar como Resposta” para beneficiar outros membros da comunidade que estejam lendo este thread”.
    Atenciosamente,
    Harley Araujo
    • Sugerido como Resposta Harley Araujo segunda-feira, 26 de outubro de 2009 10:29
    • Marcado como Resposta Eujobi segunda-feira, 26 de outubro de 2009 14:08
    segunda-feira, 26 de outubro de 2009 10:29
  • Olá Harley Araújo.
    Obrigado pela resposta.

    O erro que aconteceu eu não me lembro pois estou no trabalho e não dá pra ver. Mas eu baixei um execuável com extenção msi se não me engano. e agora aparece o "ASP.NET AJAX-Enable Web Site". O erro ocorreu somente com a página defaut.aspx mas com a master page não ocorreu nada mas deu tudo certo.

    um abraço!

    """Disse Jesus: Eu Sou o Caminho e a Verdade e a Vida; ninguém vem ao Pai senão por mim. Jo14:6.Procure uma igreja evangelica e entregue sua vida a JESUS e o deixe salvá-la!!!"""



    segunda-feira, 26 de outubro de 2009 14:08