none
Ao enviar um e-mail recebo este erro (Invalid HELO name (See RFC5321 4.1.1.1)) RRS feed

  • Pergunta

  • Olá pessoal,

    Minha duvida é a seguinte, no sistema que desenvolvo tem opção de enviar email direto do sistema, como por exemplo email da NFe e arquivos. eu utilizo a seguinte configuração para enviar o email.

    MailMessage mensagemEmail = new MailMessage();
               
    mensagemEmail.To.Add("emailcliente@email.com.br");
    
    mensagemEmail.From = new MailAddress("emailempresa@email.com.br", "Nome Empresa");
    mensagemEmail.Subject = Assunto;
    mensagemEmail.Body = "<pre>" + Mensagem + "</pre>";
    
    mensagemEmail.IsBodyHtml = true;
    
    SmtpClient client = new SmtpClient();
    client.Host = mail.dominio.com.br;
    client.Port = 587;
    client.EnableSsl = False;
    
    //Email do dominio hostgator
    //utilizo essa configuração em todos os clientes
    string Usuario = "Emailpadrao@email.com.br";
    string Senha = "Senha";
    
    NetworkCredential cred = new NetworkCredential(Usuario, Senha);
    client.Credentials = cred;
    client.Send(mensagemEmail);

    Só que o que acontece, na maioria dos clientes funciona normalmente mas em alguns tive problema de retornar este erro(Invalid HELO name (See RFC5321 4.1.1.1)).

    Em alguns testes que fiz para tentar solucionar, se eu colocar esta mesma configuração no outlook 2010 e fazer aquele teste de envio dele resolve o problema no sistema também.

    Preciso descobrir o que o outlook muda na configuração do windows para liberar o envio de email.

    Alguém tem alguma idéia???


    quinta-feira, 12 de janeiro de 2017 11:26

Respostas

  • Bom dia Diego,

    É possível que no Outlook o servidor outgoing está utilizando as mesmas configurações do servidor incoming. Talvez você precise configurar o servidor SMTP.

    Veja se as informações nessa thread o ajudam.

    Atenciosamente,


    Robson William Silva

    Esse conteúdo é fornecido sem garantias de qualquer tipo, seja expressa ou implícita

    MSDN Community Support

    Por favor, lembre-se de Marcar como Resposta as postagens que resolveram o seu problema. Essa é uma maneira comum de reconhecer aqueles que o ajudaram e fazer com que seja mais fácil para os outros visitantes encontrarem a resolução mais tarde.

    quinta-feira, 12 de janeiro de 2017 18:45
    Moderador

Todas as Respostas

  • Bom dia Diego,

    É possível que no Outlook o servidor outgoing está utilizando as mesmas configurações do servidor incoming. Talvez você precise configurar o servidor SMTP.

    Veja se as informações nessa thread o ajudam.

    Atenciosamente,


    Robson William Silva

    Esse conteúdo é fornecido sem garantias de qualquer tipo, seja expressa ou implícita

    MSDN Community Support

    Por favor, lembre-se de Marcar como Resposta as postagens que resolveram o seu problema. Essa é uma maneira comum de reconhecer aqueles que o ajudaram e fazer com que seja mais fácil para os outros visitantes encontrarem a resolução mais tarde.

    quinta-feira, 12 de janeiro de 2017 18:45
    Moderador
  • Bom dia,

    Devido a falta de interação do autor dessa pergunta,

    essa thread está sendo fechada. Caso o problema ainda

    esteja ocorrendo, favor abrir uma nova thread.

    Atenciosamente,


    Robson William Silva

    Esse conteúdo é fornecido sem garantias de qualquer tipo, seja expressa ou implícita

    MSDN Community Support

    Por favor, lembre-se de Marcar como Resposta as postagens que resolveram o seu problema. Essa é uma maneira comum de reconhecer aqueles que o ajudaram e fazer com que seja mais fácil para os outros visitantes encontrarem a resolução mais tarde.

    segunda-feira, 16 de janeiro de 2017 11:32
    Moderador
  • Não é esse o problema! não consegui resolver ainda !

    quinta-feira, 9 de março de 2017 19:39