none
Erro - acesso a banco de dados RRS feed

  • Pergunta

  • Amigos, boa tarde.

    Estou tentando abrir um projeto na minha máquina e estou recebendo a mensagem de erro abaixo, poderiam me ajudar?

    controle de origem - não é possível acessar o banco de dados

    o plug-in de controle de origem associado não está instalado ou não pôde ser inicializado.

    -Trabalhar sem controle temporariamente
    microsoft visual studio tentará reconectar a solução ou o projeto ao controle de origem depois de fechar e reabrir a solução.

    - Trabalhar offline em modo desconectado
    Você precisa usar a caixa de diálogo Alterar Controle de Origem mais tarde para reconectar a solução ou o projeto ao controle de origem.

    - Remover permanentemente ligações de associação de controle de origem

    Tenho acesso ao banco, e os dados para conexão, mas não sei onde atualizar estas informações.

    Abraço,

    Márcio E de Souza

    terça-feira, 10 de março de 2015 20:21

Respostas

  • Na opção Plug-in Selection, tem que estar marcado como None (Nenhum). Está assim?

    Ou no momento que você reabrir a solução. Escolha a opção "Remover permanentemente ligações de associação de controle de origem"

    terça-feira, 10 de março de 2015 20:57

Todas as Respostas

  • Boa tarde, Márcio

    Acredito que estas mensagens que você está recebendo são referentes ao acesso ao Source Control.

    No Visual Studio > Menu Tools (Ferramentas) > Options > Source Control.

    Procure verificar se você está tendo problemas com a conexão de rede, pois estas mensagens indicam que você está desconectado do Source Control Server.

    Qualquer coisa, só avisar.

    Abraço,

    terça-feira, 10 de março de 2015 20:30
  • estou trabalhando local, tenho o banco e o projeto na minha máquina.

    acredito que o técnico que trabalhou neste projeto antes, utilizava algum controle de versão, mas não tenho mais o contato dele.

    Sabe como posso desabilitar? No Visual Studio > Menu Tools (Ferramentas) > Options > Source Control não tem nada setado.

    terça-feira, 10 de março de 2015 20:53
  • Na opção Plug-in Selection, tem que estar marcado como None (Nenhum). Está assim?

    Ou no momento que você reabrir a solução. Escolha a opção "Remover permanentemente ligações de associação de controle de origem"

    terça-feira, 10 de março de 2015 20:57
  • Marcio boa tarde,

    Como o Demetrio disse, o teu problema não é com relação ao produto em si (conexão com banco ou outras coisas) e sim com o version control. Para que essa mensagem não seja exibida você precisa "zerar" as referencias para o version control antigo, mas para isso precisa saber antes qual era (TFS, SVN, Source Safe, etc), com isso você consegue tirar as referencias e trabalhar sem a necessidade de ficar dando OK nessa mensagem.

    Att.


    Guilherme Silva Cardoso

    terça-feira, 10 de março de 2015 21:00