none
VS2005 com Asp antigo. RRS feed

  • Pergunta

  • Fala Pessoal!

    Bem, estou com um probleminha em rodar páginas asp antigas nas minhas aplicações, falo isto porque estou tendo que integrar páginas antigas com aspx.

    Creio que deva ser alguma configuração que tenha que fazer no IIS ou no próprio VS, só que estou meio enrolado e não estou conseguindo achar, ficaria grato se alguém pudesse dar alguma dica.

    Falou!!

     

    sábado, 3 de junho de 2006 18:24

Todas as Respostas

  • Oi Bahia

    Vc está conseguindo rodar alguma pagina ASP? Ou não conseguiu rodar nenhuma. Não lembro se o ASP3 vem instalado por padrão, então da uma olhada aqui:
    Painel de Controle -> Adicionar/Remover Programas -> Adicionar/Remover Componentes do Windows -> Servidor de Aplicações -> Internet Information Services -> WorldWideWeb Service -> Active Server Pages

    Que canseira!

    []'s
    Fábio Alves

     

    sábado, 3 de junho de 2006 21:41
  • Fala Fábio!
    Realmente, não consigo abrir nenhuma página asp, geralmente quando o asp está ok o localhost funciona, certo?

    Só a nível de informação, dentro de WorldWideWeb Service, tenho marcado:

    Diretório Virtual de Impressoras
    Diretório Virtual de Scripts
    Serviço da World Wide Web

    O que não está marcado é

    Conexão da web da área de trabalho remota, que acho que não tem nada haver.

    Falou!

    segunda-feira, 5 de junho de 2006 01:11
  • Bahia ,

     

    Veja se em Diretorio Virtual->configurações tem o mapeamento para asp ele deve esta apotando para o C:\WINDOWS\system32\inetsrv\asp.dll.

    segunda-feira, 5 de junho de 2006 11:42
  • Fábio, só para registrar, na verdade o problema de conseguir rodar páginas asp antigas, é na minha máquina em casa, aqui no trabalho, verifiquei que rodam, (além do aspx), olhando superficialmente não detectei diferença na configuração...depois verifico com mais calma pois o importante mesmo agora, é conseguir fazer que minhas páginas aspx, funcionem em conjunto com as antigas, ou seja, se tenho na minha aplicação /teste/pagina1.aspx, a mesma deverá exibir /teste/pagina2.asp sem problemas.

    Quando rodo a aplicação a partir do VS2005 ela abre numa determinada porta, que por sua vez, não funciona a páginas asp antiga, retirando a porta, funciona a antiga.

    Alguma sugestão?

    Desde já agradecido pela colaboração;

    Falou!

    segunda-feira, 5 de junho de 2006 12:09
  • Pessoal, obrigado pela ajuda!

    O problema que tinha citado acima, a partir do VS2005 conseguir trabalhar com o aspx e um eventual asp, não totalmente resolvido, devido a porta que é gerada.

    Entretanto, quando publico o projeto, colocando o diretório virtual, etc, fica funcionando.

    Como não quero me deter muito na questão do VS, vou partir logo para integrar as Sessões das aplicações asp antigas com as novas agora.

    Estou lendo o artigo: http://msdn.microsoft.com/library/default.asp?url=/library/en-us/dnaspp/html/converttoaspnet.asp

    E outros também que a turma do fórum já enviaram em outros posts.

    A princípio, as que estou lendo, todas utilizam como intermediário o Banco, criando uma tabela que vai conter os dados, se todos forem assim, terei que usar criptografia nestas gravações, já que não posso deixar exposto tais informações, mesmo que elas sejam excluídas após o uso... bom mas vou pesquisar um pouco mais...

    Se alguém já fez isso, por favor me indique a fonte de pesquisa, pois aí já vou direto num case de sucesso.

    Abraço.

    segunda-feira, 5 de junho de 2006 14:23