none
Cache no IIS... RRS feed

  • Pergunta

  • Pessoal é uma dúvida que eu não sabia onde postar, então como o pessoal de ASP geralmente tbm fica futucando o IIS...rs...

    Seguinte estou com um problema com meu IIS que só acontece com meus arquivos .CSS...

    Parece que o IIS cria um cache desse arquivo em algum momento q estou mexendo e não o libera mais, apenas se eu reinicia-lo, então várias vezes ao dia estou mexendo em um CSS, alterando e testando no navegador, aí chega em momento q as minhas alterações param de responder no navegador, então tenho que reiniciar o IIS, o estranho é q só acontece com CSS...

     

    alguém já passou por isso?

     

    vlw!

    quarta-feira, 11 de outubro de 2006 17:16

Todas as Respostas

  • Ja tentou limpar o cache do seu browser??

     

    quarta-feira, 11 de outubro de 2006 17:44
  • é pra responder mesmo?...rs
    quarta-feira, 11 de outubro de 2006 19:27
  • José Serra.

    Aqui tembém tenho problemas com cache de css. Mas nada que precise reiniciar o IIS.
    Basta limpar o cache do browser.
    Mas vc pode tbm trocar o nome do arquivo css que fica tudo certo.

    quarta-feira, 11 de outubro de 2006 19:32
  • então deixa eu detalhar mais...

    nem limpando o cache funciona...
    mesmo acessando de outra máquina não funciona...
    mesmo desligando o computador ou reiniciando o mesmo...

    só funciona se eu reiniciar o IIS, e isso acontece apenas com CSS...

    vlw...agradeço a ajuda... mas alguém sabe do q se trata?
    quarta-feira, 11 de outubro de 2006 19:42
  • Ai o bixo pego.... hehehe

    quarta-feira, 11 de outubro de 2006 19:46
  • Tenta renomear o arquivo .CSS
    Com verteza o iis vai procurar pela última versão
    quarta-feira, 11 de outubro de 2006 19:51
  • pra ter uma idéia...
    eu até já deletei o arquivo...rs
    mas nada... só reiniciando mesmo...

    e tbm eu gostaria de resolver o problema, e não ficar maquiando...

    será que existe alguma atualização do mesmo?

    vlw
    quarta-feira, 11 de outubro de 2006 19:57
  • Serr.
    Tenta colocar isso nas primeiras linhas de seus arquivos.
    Talvez te ajude.

    <%
       RESPONSE.BUFFER=FALSE
       RESPONSE.EXPIRES=0
       Response.Expires = 60
       Response.Expiresabsolute = Now() - 1
       Response.AddHeader "pragma","no-cache"
       Response.AddHeader "cache-control","private"
       Response.CacheControl = "no-cache"
    %>

    • Sugerido como Resposta Rafael Boschini quinta-feira, 16 de agosto de 2012 14:36
    sexta-feira, 20 de outubro de 2006 16:24
  • Ola Serra,

    Qual IIS vc esta utilizando?

    Abraços!

    Wagner Amorim

    sábado, 21 de outubro de 2006 01:00
  • No meu IIS também acontece isso, só que uso o IIS 6.1 com windows 7
    terça-feira, 11 de janeiro de 2011 15:36
  • Humildade Brodi
    sábado, 1 de outubro de 2011 00:46
  • Tb tive esse problema, tenta renomear o arquivo .css, como o Glauber Rocha falou, aqui conssegui resolver assim... xD
    quarta-feira, 26 de outubro de 2011 13:43
  • Pessoal,

    Cache de IIS, provavelmente está configurado para cache de arquivos .CSS.

    No arquivo:

    http://labs.episerver.com/en/Blogs/Per/Archive/2009/3/Configuring-cache-expiration-on-IIS-7/

    http://brunotorres.net/evitando-caching-css-somente-quando-atualizado

    ou no IIS:

    http://bradkingsley.com/enable-caching-in-iis-to-speed-performance/

    Abraços

    quarta-feira, 15 de agosto de 2012 21:54
  • Amigo,

    Adicione um incremento no nome do arquivo é uma solução rápida e fácil, ex:

    <link href="../css/estilo.css?data=<%=now()%>" rel="stylesheet" type="text/css">

    Com esse incremento ele sempre vai pegar uma versão nova a cada F5.

    Espero ter ajudado e boa sorte!


    Não esqueça de marcar como útil uma resposta que te ajude.
    "A diversão é a alma do negócio"

    segunda-feira, 20 de agosto de 2012 16:43