none
Ativar JavaScript WebBrowser, não funciona? RRS feed

  • Pergunta

  • TODOS os lugares que encontrei a resposta, SEM EXCEÇÃO, o código é simples: WebBrowser1.IsScriptEnabled = True. Estou usando VS 2013 Express. Esse IsScriptEnabled simplesmente não existe, em lugar nenhum encontrei opção sobre isso, e o código não é reconhecido. Não estou entendendo, o que está acontecendo?
    domingo, 26 de julho de 2015 05:17

Respostas

  • O WebBrowser é um motor antigo do IE e muitos jscrips não vão rodar nele, você pode alterar as configurações para rodar a versão mais atual, por esse site:

    http://www.west-wind.com/weblog/posts/2011/May/21/Web-Browser-Control-Specifying-the-IE-Version

    Porém, uma boa é usar o WebKit (http://webkitdotnet.sourceforge.net/basics.php).

    • Marcado como Resposta Marcos SJ sexta-feira, 31 de julho de 2015 18:51
    segunda-feira, 27 de julho de 2015 13:29

Todas as Respostas

  • O WebBrowser é um motor antigo do IE e muitos jscrips não vão rodar nele, você pode alterar as configurações para rodar a versão mais atual, por esse site:

    http://www.west-wind.com/weblog/posts/2011/May/21/Web-Browser-Control-Specifying-the-IE-Version

    Porém, uma boa é usar o WebKit (http://webkitdotnet.sourceforge.net/basics.php).

    • Marcado como Resposta Marcos SJ sexta-feira, 31 de julho de 2015 18:51
    segunda-feira, 27 de julho de 2015 13:29
  • Boa tarde,

    Por falta de retorno do usuário, esta thread será encerrada.

    Caso seja necessário, por gentileza, abra uma thread nova.

    Atenciosamente


    Marcos Roberto de Souza Junior

    Esse conteúdo e fornecido sem garantias de qualquer tipo, seja expressa ou implícita

    MSDN Community Support

    Por favor, lembre-se de Marcar como Resposta as respostas que resolveram o seu problema. Essa e uma maneira comum de reconhecer aqueles que o ajudaram e fazer com que seja mais fácil para os outros visitantes encontrarem a resolução mais tarde.

    sexta-feira, 31 de julho de 2015 18:51