none
Comparar Valores RRS feed

  • Pergunta

  • Preciso comparar numa planilha de excel, se tenho telefones repetidos.

    Ex:

          Nome                    Telefone

           João                     31-35443099

           Matheus               99887639

          Pedro                    +553135443099

    Repare que o telefone do João e do Pedro são o mesmo porem um tem 031 e o outro +5531. Como que faço para identificar esses valores?

    quarta-feira, 27 de julho de 2016 00:41

Todas as Respostas

  • Olá Marcos!

    Eu não recorreria ao vba para fazer este tipo de análise. Aplicando adequadamente algumas funções você consegue fazer uma analise diretamente na planilha. Veja um exemplo levando em conta a análise dos 8 digitos da direita dos telefones.

    Na coluna C eu padronizei os números retirando os hifens e sinal de +.

    Na coluna D a fórmula para contar quantos números com os 8 último digitos iguais.

    Na coluna E uma fórmula matricial para dizer em qual linha está a repetição.

    Você pode aplicar este modelo para a sua base completa, que creio que será fácil de filtrar e ir analisando.

    As fórmulas que aplique na sequência são:

    =SUBSTITUIR(SUBSTITUIR(B2;"-";"");"+";"")

    =CONT.SE($C$2:$C$4;"*"&DIREITA(C2;8))

    =SEERRO(MÍNIMO(SE((DIREITA($C$2:$C$4;8)=DIREITA(C2;8))*(LIN($C$2:$C$4)<>LIN());LIN($C$2:$C$4);""));"")

    Esta última deve ser inserida com CTRL+SHIFT+ENTER.

    Abraços!


    Rafael Kamimura - http://excelmaniacos.com


    • Editado Rafael Kamimura quarta-feira, 27 de julho de 2016 12:51
    • Sugerido como Resposta André Santo quarta-feira, 27 de julho de 2016 14:37
    quarta-feira, 27 de julho de 2016 12:50