locked
Tempo de vida RRS feed

  • Pergunta

  • Boa  tarde !!!

     

    Tenho uma planilha que contem informação de produtos com data de fabricação , a minha pergunta é a seguinte ha possibilidade de fazer uma macro ou uma formula que me mostre o tempo de vida desse produto com base no ano atual.

    tipo  produto x

            data fabricação : 20/05/2000

             tempo de vida : 10 anos.

     

    obrigadoo

     

     

    quarta-feira, 30 de junho de 2010 21:31

Todas as Respostas

  • Lango boa noite


    Você pode fazer assim

    Se os dados estiverem dispostos da seguinte forma faça

                 A                       B                      C
    1 Data de Fabricação   Anos/Validade

    2 20/05/2000                    10                 =SE(A2+(B2*365)<=HOJE();"Produto Vencido";"Produto Válido")

    Esta Fórmula irá verificar se já se passaram 10 anos até hoje, se sim mostrará produto vencido, se não mostrará Produto Válido.

    Atenciosamente


    Bruno Silva Leite Office Developer
    quarta-feira, 30 de junho de 2010 22:59
  • Bruno 

    Bom dia !!!!!

    Então a informação que tenho sobre o produto é somente a data de fabricação no caso exemplo 03/02/2002 .

    eu sei que ele tem 8 anos de existência pq de 2002 pra 2010 são 8 anos.

    Como são muitos produtos eu queria uma formula que me traz  ja o resultado de cada um.

    grato. 

    quinta-feira, 1 de julho de 2010 12:36
  • Olá,

     

    fiz esta fórmula para calcular a Idade, veja se atende:

    =YEAR(TODAY())-YEAR(A2)+(IF(OR(MONTH(TODAY())<MONTH(A2);AND(MONTH(TODAY())=MONTH(A2);DAY(TODAY())<DAY(A2)));-1;0))

    =ANO(HOJE())-ANO(A2)+(SE(OU(MÊS(HOJE())<MÊS(A2);E(MÊS(HOJE())=MÊS(A2);DIA(HOJE())<DIA(A2)));-1;0))

     

    Obs.: "A2" é a célula que tem a data de nascimento.


    Luiz Cláudio Cosenza Vieira da Rocha - http://msmvps.com/blogs/officedev - IT Lab www.itlab.com.br
    quinta-feira, 1 de julho de 2010 13:01
    Moderador
  • Bom dia !!!!!!

     

    Luiz a sua formula deu certinho, so teve um pequeno detalhe que ficou zerado quando o produto tem meses e nao anos.

    mas mesmo assim obrigado.

    quinta-feira, 1 de julho de 2010 14:13
  • Olá Lango como vai,

    Acredito que tenha duas fórmulas simples

    A primeira

    =YEARFRAC(A5;TODAY())

    Ou com ela só com anos

    =ROUNDDOWN(YEARFRAC(A5;TODAY());0)

    Ou formula direta

    =(TODAY()-A5)/365

    Ou Arredondada com anos

    =ROUNDDOWN((TODAY()-A5)/365;0)

    Lembrando que na Célula A5 está a data 

     

    Abraços,


    Baldini Fabio
    • Sugerido como Resposta Baldini quinta-feira, 1 de julho de 2010 23:32
    quinta-feira, 1 de julho de 2010 23:32
  • Lango , não será por falta de respostas..

    Você pode usar também...

    =SE((HOJE()-A2)/365<1;(HOJE()-A2)/30;(HOJE()-A2)/365)

    Que dará a resposta em anos ou meses.

    Att


    Bruno Silva Leite Office Developer
    quinta-feira, 1 de julho de 2010 23:43
  • Mais fácil assim então:

    =CONCATENATE(DATEDIF(A2;TODAY();"y");"A ";DATEDIF(A2;TODAY();"ym");"M")

    =CONCATENAR(DATADIF(A2;HOJE();"y");"A ";DATADIF(A2;HOJE();"ym");"M")

     


    Luiz Cláudio Cosenza Vieira da Rocha - http://msmvps.com/blogs/officedev - IT Lab www.itlab.com.br
    sexta-feira, 2 de julho de 2010 00:07
    Moderador