none
Exportar e Importar List RRS feed

  • Pergunta

  • Olá, gostaria da ajuda de vocês.

    Estou realizando um importação de um lista do servidor de homologação para o de Produção, utilizei 2 modos para isso, mas estou tendo problemas nas colunas da minha lista que são do tipo pessoa grupo.

    Modo Modelo

    Neste modo eu salvo o list como modelo e exporto para o servidor de produção recriando a lista usando o modelos salvo. Neste caso os campos que contém os usuários ficam em branco, sendo que os dois servidores utilizam a mesma base do AD. Depois da tabela com sua estrutura criada, eu copio os itens do servidor de homologação via "Exibição Folha de dados", ao colar os itens em produção alguns usuários são colados com sucesso outros não. Estes usuários que não são colados com sucesso ao editar o campo na "Exibição Folha de Dados" e digitar o nome completo ele não é localizado, mas se eu sair da "Exibição Folha de dados" e editar o item via site, onde no campo que contem um people picker, ao clicar no livro, e buscar novamente o nome completo, ele é localizado, assim posso seleciona-lo e salva-lo com sucesso.

    Duvida: Sabes me dizer porque o usuário não é localizado em modo "Exibição Folha de Dados" já ao editar no campo people picker ele localiza? Desta forma dos 1000 registros com usuários cadastrados, onde 229 foram colados com sucesso, os demais terei que editar um por um e busca-los manualmente nos campos people picker e salva-los.

    Modo backup granular

    Outra forma que encontrei foi realizando um Backup granular na lista e restaurando em produção, bem mais fácil sem necessidade de nenhuma intervenção, apenas que a coluna dos usuários vem em branco, havendo a necessidade de copiar e colar via "Exibição Folha de Dados" voltando ao problema acima.

    Conclusão

    Testei as dua forma acima, onde o backup se mostrou mais fácil e rápido, mas o problema no campo de usuários persiste nas duas formas. Gostaria de saber se existe uma maneira fácil de salvar e restaurar um list de forma completa até com o campo usuários para outro servidor? Ou como resolver este problema de na "Exibição Folha de Dados" não encontrar um usuário, já ao edita-los via site no campo people picker este usuário é encontrado com sucesso.


    Obrigado!


    segunda-feira, 29 de julho de 2013 21:34