none
Não consigo alterar o tema do Bootstrap projeto MVC RRS feed

  • Discussão Geral

  • Sou novo em MVC e no uso do bootstrap, estou fazendo um curso do Microsoft Virtual Academy sobre MVC5, e nesse curso o professor está usando visual studio 2013 e ensina como alterar o tema do bootstrap. Ele vai até o site BootSwatch, baixa o arquivo bootstrap.css e bootstrap.mini. css e substitui pelos orignais na pasta content do projeto e com isso a mudança ja é realizada.

    Porém, eu sigo exatamente os mesmos passos ensinado na aula e comigo não funciona, já tentei em 2 máquinas e a alteração do tema não é feita de jeito nenhum. A única diferença que pude perceber é que estou usando o Visual Studio 2017 invés do 2013. No 2017 a forma de alterar é outra ? Podem por gentileza me ajudar nisso ?

    Obrigado.

    quarta-feira, 20 de março de 2019 05:30

Todas as Respostas

  • Olá Diego.lk, bom dia! A forma de alterar é a mesma não muda por causa da versão do Visual Studio, verifica se esta mudando os arquivos certos.

    Acho que esse Link pode te ajudar. 

    Se de certo não esquece de marca como resposta. Obrigado.

    Abraços.

     
    quinta-feira, 21 de março de 2019 12:24
  • Olá, amigo.

    Obrigado pela resposta. Esse link não ajudou muito.

    Eu descobri que o visual studio 2017 trabalha nativamente com o bootstrap 3, e os temas que eu estava tentando aplicar são da versão 4 do bootstrap. Mesmo atualizando o bootstrap do visual studio pelo NuGet para a versão 4 o problema persiste. O problema acontece somente nos menus, no nav-var do layout e em alguns botões do CRUD. O tema é aplicado normalmente, porém com esses bugs.

    Já pesquisei bastante mas não consigo resolver e nem entender que mesmo atualizando o bootstrap do visual studio para a mesma versão dos arquivos do bootstrap, o problema continua.

    quinta-feira, 21 de março de 2019 16:18
  • Olá, é que no projeto padrão do VS tem o Site.css aplicando estilos, tem que ajustar ou não carregar...

    Se ajudou, vote como útil! Obrigado.

     
    quinta-feira, 21 de março de 2019 22:30
  • Removi o arquivo Site.css temporariamente do projeto, executei e o problema continua =/
    • Editado diego.lk sexta-feira, 22 de março de 2019 00:08
    sexta-feira, 22 de março de 2019 00:08