none
Erro 401 (Unauthorized) RRS feed

  • Pergunta

  • Ola a todos.

    Estou iniciando com SQL e RS agora.

    Instalei o MSSQL 2008 + Report (SP2) em um Windows 2008 R2.  Configurei tb um Webservice no IIS referente à uma aplicação VB.Net

    O que está acontecendo é que, pelo Report Manager, os relatórios são gerados. Pela aplicação, retorna a mensagem Erro 401 - Unauthorized. No Report Manager as permissões estão definidas.

    Já validei as definições de autenticação no web.config e reportserver.config, e aparentemente está tudo ok.

    Já pesquisei aqui no Fórum e na net, tentei diversas "soluções", sem sucesso. Quero esgotar todas as possibilidades antes de retornar pra equipe de DEV.

    Nao tenho muita informação para passar, por não conhecer a fundo a solução (ainda). Existe algum outro parâmetro que eu possa verificar?

    Grato pela ajuda.

    Dan Pinheiro.


    Dan Pinheiro RJ - Brasil
    segunda-feira, 19 de setembro de 2011 18:07

Todas as Respostas

  • Vamos lá: como você está chamando o relatóri a partir da aplicação? existe um método que precisa ser executado nesta "chamada", através do qual são passadas as credenciais para conexão ao report.
    SQL SERVER sempre
    sexta-feira, 23 de setembro de 2011 17:23
  • Dan,

    Por fora da aplicação você acesso o relatório normalmente!!! Nas propriedades de conexão do seu relatório, você configurou qual conta de usuário e forma de login?

    No IIS você configurou conexão não autorizada?


    Pedro Antonio Galvão Junior [MVP | Microsoft Evangelist | Microsoft Partner | Engenheiro de Softwares | Especialista em Banco de Dados | SorBR.Net | Professor Universitário | MSIT.com]
    sábado, 24 de setembro de 2011 14:02
  • Sim, por fora o relatório funciona....
    Dan Pinheiro RJ - Brasil
    sexta-feira, 7 de outubro de 2011 19:14
  • Dan Pinheiro,

    Cara o problema esta no usuário que você esta conectada via aplicação, verifique se o mesmo possui permissão e se esta configurado no diretório virtual do IIS para ter acesso a esta relatório, com também, na pasta ao qual o relatório se encontrar armazenado.


    Pedro Antonio Galvão Junior [MVP | Microsoft Evangelist | Microsoft Partner | Engenheiro de Softwares | Especialista em Banco de Dados | SorBR.Net | Professor Universitário | MSIT.com]
    domingo, 9 de outubro de 2011 19:54
  • Dan,

     

    Alem de todas as sugestões dos amigos Pedro e Adeilson, eu tive problemas parecidos, e bom, ainda esta pendente a solução (estou um pouco atarefado rs...), todo caso, estou tendo problema por autenticação automatica com o AD em um cliente, eu apenas alterei para não re-autenticar no IIS ao entrar no Pool (SSRS), e passou a funcionar. Lembrando que ainda não é solução, e sim um contorno temporario, assim que tiver um solução definitiva para este, posto aqui.


    Fabrizzio A. Caputo
    Certificações:
    Oracle OCA 11g
    MCITP SQL Server 2008 Implementation and Maintenance
    MCITP SQL Server 2008 Developer
    Blog Pessoal: www.fabrizziocaputo.wordpress.com
    Blog Empresa: www.tripletech.com.br/blog
    Twitter: @FabrizzioCaputo
    Email: fabrizzio.antoniaci@gmail.com
    terça-feira, 11 de outubro de 2011 02:40
    Moderador
  • Pessoal, agradeço a ajuda de todos.

    O problema esta na procedure que gera o relatório, não estava passando os argumentos de user e senha... como RS 2008 não permite acesso anônimo, estava retornando a mensagem.

    Obrigado a todos.

     


    Dan Pinheiro RJ - Brasil
    sexta-feira, 21 de outubro de 2011 10:29