none
Problema do Report Server na instalação do TFS RRS feed

  • Pergunta

  • Senhores,

    na instalação do TFS dá o seguinte erro:

    Error 29112. Team Foundation Report Server Configuration: Report Server is not properly configured or the Reporting Services Web site could not be reached. Use the Report Server Configuration tool to confirm that Report Server is configured properly and that the Reporting Service Web site can be found before running the installation again.

     

    E quando vou no Report Server Configuration tool, a initialization não está configurada, dá o seguinte erro:

    There was an error while switching panels. The most likely cause is an error retrieving WMI properties. The exception details are:

    The report server cannot open a connection to the report server database. A connection to the database is required for all requests and processing. (rsReportServerDatabaseUnavailable)

    Não tenho a mínima ideia do que fazer, portanto se alguém tiver paciencia, por favor me ajude!

    quarta-feira, 3 de janeiro de 2007 19:55

Respostas

  • Tive o mesmo problema, acessei o Report Server Configuration (Todos os Programas - Microsoft SQL Server 2005 - Configuration Tools = Reporting Services Configuration) e fiz todas as configurações manualmente. na seguinte ordem:

    Report Server Virtual Directory - Clique em New e crie o diretorio

    Report Manager Virtual Directory - De novo em New

    Windows Service Identity - Local System

    Web Service Identity - Só cliquei em Apply

    Database Setup - Escolha seu servidor em Server Name e no Database clique em New

    Configurei o Email settings tmbm, mas isso não precisa.

    Não esqueça de aplicar Apply em todos os formularios

     

    Depois disso teste no seu navegador http://localhost/reports

     

    se aparecer tudo ok, volte ao instador e deve funcionar, funcionou comigo.

     

    Valeu

    quarta-feira, 2 de maio de 2007 05:13

Todas as Respostas

  • Olá RSilva,

    Olhando em outro fórum: http://forums.microsoft.com/MSDN/ShowPost.aspx?PostID=274181&SiteID=1 em uma pergunta muito semelhante à sua, me parece que o seu problema é com o collation do SQL. Vc notou no installation guide do Team Fondation que há instruções bem específicas com relaçõa ao collation?

    Se não for muito complicado, instale novamente o SQL com o collation compatível e veja se resolve o problema.

    sexta-feira, 5 de janeiro de 2007 17:48
  • Olá Rsilva,

    Existe um hotfix para o SQL Server ( KB913393) que deve ser instalado, chegou a fazer isso? se não baixe-o a partir daqui: http://go.microsoft.com/fwlink/?LinkId=62733

    []´s

     

    domingo, 7 de janeiro de 2007 15:18
  • Tive o mesmo problema, acessei o Report Server Configuration (Todos os Programas - Microsoft SQL Server 2005 - Configuration Tools = Reporting Services Configuration) e fiz todas as configurações manualmente. na seguinte ordem:

    Report Server Virtual Directory - Clique em New e crie o diretorio

    Report Manager Virtual Directory - De novo em New

    Windows Service Identity - Local System

    Web Service Identity - Só cliquei em Apply

    Database Setup - Escolha seu servidor em Server Name e no Database clique em New

    Configurei o Email settings tmbm, mas isso não precisa.

    Não esqueça de aplicar Apply em todos os formularios

     

    Depois disso teste no seu navegador http://localhost/reports

     

    se aparecer tudo ok, volte ao instador e deve funcionar, funcionou comigo.

     

    Valeu

    quarta-feira, 2 de maio de 2007 05:13
  • quarta-feira, 6 de junho de 2007 14:56