none
Breakpoints não funcionam mais RRS feed

  • Pergunta

  • Pessoal,

    Estou utilizando o Visual Studio 2008, Windows 7 e IE 9 (tb utilizo FireFox e Chrome). Os breakpoints que coloco, não está parando em nenhum. Em "Solution Configuration", está em Debug.

    Alguém já teve esse problema?

    sexta-feira, 10 de dezembro de 2010 20:08

Respostas

Todas as Respostas

  • Tente colocar na primeira linha do código e debugar linha a linha, já aconteceu comigo de por um erro no código não lançar exceção, ele para de executar o debug em determinado ponto.
    sábado, 11 de dezembro de 2010 00:20
  • Tente colocar na primeira linha do código e debugar linha a linha, já aconteceu comigo de por um erro no código não lançar exceção, ele para de executar o debug em determinado ponto.

    Tentei fazer, o que vc disse, mas mesmo assim, continua não parando no breakpoint.

    O estranho, é que qdo clico no "Play", ele roda a aplicação e o botão de "Play", já volta à ficar verde, não fica cinza durante a execução da aplicação.

    sábado, 11 de dezembro de 2010 16:47
  • No visual studio tente: Menu: Tools > Attach to Process

    Attach seu processo do browser que a aplicacao esta rodando.


    Ederson Lima O maior problema do Desenvolvimento de Sistemas usando as atuais e poderosas Linguagens de Programação e Sistemas Gerenciadores de Bases de Dados é a facilidade de se fazer malfeito e a grande dificuldade de se fazer bem-feito.
    sábado, 11 de dezembro de 2010 17:41
  • No visual studio tente: Menu: Tools > Attach to Process

    Attach seu processo do browser que a aplicacao esta rodando.


    Ederson Lima O maior problema do Desenvolvimento de Sistemas usando as atuais e poderosas Linguagens de Programação e Sistemas Gerenciadores de Bases de Dados é a facilidade de se fazer malfeito e a grande dificuldade de se fazer bem-feito.

    Oi Ederson,

    Tentei fazer o que vc me disse, mas continua com o mesmo problema. =/

    domingo, 12 de dezembro de 2010 00:47
  • veja se no menu debug, a opção Disable all breakpoints está desativada

    feche todas as instâncias dos navegadores. Use apenas aquela que será aberta durante a compilação

    domingo, 12 de dezembro de 2010 18:56
  • veja se no menu debug, a opção Disable all breakpoints está desativada

    feche todas as instâncias dos navegadores. Use apenas aquela que será aberta durante a compilação

    Oi Sandro,

    No menu Debug, a opção de desabilitar os breakpoints, está inativa. Já tentei deixar, somente a janela do browser que vou usar, mas mesmo assim nada. Tentei com o IE9, FireFox e Chrome. E nenhum deles, funciona.

    Mais alguma dica?

    segunda-feira, 13 de dezembro de 2010 09:40
  • veja se no menu debug, a opção Disable all breakpoints está desativada

    feche todas as instâncias dos navegadores. Use apenas aquela que será aberta durante a compilação

    Oi Sandro,

    No menu Debug, a opção de desabilitar os breakpoints, está inativa. Já tentei deixar, somente a janela do browser que vou usar, mas mesmo assim nada. Tentei com o IE9, FireFox e Chrome. E nenhum deles, funciona.

    Mais alguma dica?

    Faz um reset no seu vs
    segunda-feira, 13 de dezembro de 2010 10:27
    Moderador
  • veja se no menu debug, a opção Disable all breakpoints está desativada

    feche todas as instâncias dos navegadores. Use apenas aquela que será aberta durante a compilação

    Oi Sandro,

    No menu Debug, a opção de desabilitar os breakpoints, está inativa. Já tentei deixar, somente a janela do browser que vou usar, mas mesmo assim nada. Tentei com o IE9, FireFox e Chrome. E nenhum deles, funciona.

    Mais alguma dica?

    Faz um reset no seu vs
    Como faço isso? rs..
    segunda-feira, 13 de dezembro de 2010 12:53
  • veja se no menu debug, a opção Disable all breakpoints está desativada

    feche todas as instâncias dos navegadores. Use apenas aquela que será aberta durante a compilação

    Oi Sandro,

    No menu Debug, a opção de desabilitar os breakpoints, está inativa. Já tentei deixar, somente a janela do browser que vou usar, mas mesmo assim nada. Tentei com o IE9, FireFox e Chrome. E nenhum deles, funciona.

    Mais alguma dica?

    Faz um reset no seu vs
    Como faço isso? rs..


    Veja

    http://msdn.microsoft.com/en-us/library/ms247075%28v=vs.80%29.aspx

    segunda-feira, 13 de dezembro de 2010 14:26
    Moderador
  • Seilor, 

    Fiz o reset, mas mesmo assim, não funciona. =(

    O estranho, é que qdo clico no Play, ele roda o projeto, mas logo o botão Play, volta a fica disponível de novo, ele não trava o Play, quando roda o aplicativo.

    segunda-feira, 13 de dezembro de 2010 14:51
  • ola..

    No meu VS 2005, tenho este problema  às vezes. Notei que isso acontece quando eu tinha várias instâncias dos navegadores aberto. Fechando todas  e pressionando F5, para compilar, ele abre uma nova instância do navegador definido no VS como padrão e tudo funciona normalmente de novo.

    Não pesquisei para saber o motivo deste comportamento. Apenas procedendo desta maneira, funciona.

     

    Lembrando que deve estar em modo Debug no VS. Acerte isso no seu projeto e veja a configuração que esta no web.config, na tag. Deve estar igual a --> <compilation debug="false">

     

     

    • Sugerido como Resposta Erysson Souza segunda-feira, 13 de dezembro de 2010 18:22
    segunda-feira, 13 de dezembro de 2010 17:13
  • ola..

    No meu VS 2005, tenho este problema  às vezes. Notei que isso acontece quando eu tinha várias instâncias dos navegadores aberto. Fechando todas  e pressionando F5, para compilar, ele abre uma nova instância do navegador definido no VS como padrão e tudo funciona normalmente de novo.

    Não pesquisei para saber o motivo deste comportamento. Apenas procedendo desta maneira, funciona.

     

    Lembrando que deve estar em modo Debug no VS. Acerte isso no seu projeto e veja a configuração que esta no web.config, na tag. Deve estar igual a --> <compilation debug="false">

     

     

    Oi Sandro,

    Dei uma pesquisada na net sobre o problema, e li sobre exatamente essa opção que vc falou do web.config. Mas lá no artigo, diz pra deixar em true. O meu está como true, amanhã faço um novo teste, e posto aqui.

    Obrigado pela força.. =)

    segunda-feira, 13 de dezembro de 2010 20:14
  • Sandro, baixei o projeto aqui na minha máquina..

    No meu web.config, estava como true. Alterei para false, mas mesmo assim, não funciona.

    Estou desistindo de tentar configurar isso, e vou partir para ignorância.. rs.. vou reinstalar o VS, será que resolve?

    segunda-feira, 13 de dezembro de 2010 20:40
  • sorry...

    era para estar igual a true.. foi falha minha...

    mas se nao resolveu, até agora, reinstalar seria uma boa...

    terça-feira, 14 de dezembro de 2010 01:53
  • Pessoal,

    Esse problema, parece ser um bug do VS2008 mesmo. Tem um fix, mas parece que não resolve o problema.. rs. 

    O fix é esse:

    http://code.msdn.microsoft.com/Project/Download/FileDownload.aspx?ProjectName=KB957912&DownloadId=3803

    Na MSDN americana, tem um tópico sobre o assunto, mas o fix, não funcionou para maioria. O link do tópico, é esse:

    http://social.msdn.microsoft.com/Forums/en/vsdebug/thread/f3fcb4fb-8a08-4fa0-8d58-9ed6f3eb1193

    Bom, tudo certo e nada resolvido!  =/

    terça-feira, 14 de dezembro de 2010 09:49
  • Oi Sandro,

    Meu problema é diferente do pessoal dos links, que vc enviou. No meu caso, eu consigo setar os breakpoints.. só que na execução do projeto, ele não pára em nenhum..

    terça-feira, 14 de dezembro de 2010 15:14
  • Oi pessoal,

    Consegui resolver o problema. Atualizei pro VS2010.  =)

    • Marcado como Resposta Guilherme_ segunda-feira, 20 de dezembro de 2010 14:36
    segunda-feira, 20 de dezembro de 2010 14:36