none
Aplicação usando as configurações da machine.config RRS feed

  • Pergunta


  • Olá Senhores(as),
    Não sei o que está ocorrendo com minha aplicação web, que estava funcionando perfeitamente e agora está pegando as configurações da machine.config e não do web.config da aplicação.
    Alguém poderia me ajudar por favor.
    Os arquivos estão no C:\projetos\aplicacao e eu publico em C:\inetpub\wwwroot\
    Obrigado,
    quinta-feira, 18 de abril de 2013 15:25

Todas as Respostas

  • tente reinstalar o asp.net 4.0

    C:\Windows\Microsoft.NET\Framework\v4.0.30319>aspnet_regiis.exe -i




    quinta-feira, 18 de abril de 2013 16:55
  • Ele esta reclamando que, não esta achando uma secão connectionString no machine ou web config que tenha o nome "LocalSqlServer". o IIS junta este dois config e faz um só.

    Será que você não estar dando um clear no seu web.config na seção connectionString? Tipo

    <connectionStrings>
        <clear/>
        <!-- suas conexao string-->
      </connectionStrings>


    quinta-feira, 18 de abril de 2013 20:01
    Moderador
  • Obrigado pessoal, mas quando tudo da errado, a melhor opção é refazer.
    Eu Reinstalei a frameworks seguindo a orientação do Leonel, mas não resolveu.
    O meu web.config não estava com a tag clear, conforme orientado pelo Wellington Jr.
    Eu criei um novo projeto do zero e passei os arquivos de um lado para o outro, tomando cuidado com informações como link e esta funcionando.
    Problemas como esse, é bom entender para ficar fera.
    Obrigado a todos.
    • Editado Fabrício MD sexta-feira, 19 de abril de 2013 15:19
    sexta-feira, 19 de abril de 2013 15:19