none
erro na hora de criar uma assinante na replicação RRS feed

  • Pergunta

  • Criei um servidor(bronze) e distribuidor de replicação e criei os artigos para serem publicados, em outro servidor (cromo) eu tentei fazer com que ele seja o destino (assinante) das publicaçõe, mas ocorre o seguinte erro:

    SQL Server Enterprise Manager encountered errors creating push subscriptions
    for the following Subscribers:

    [Subscriber Server Name]: Error 14053: Cannot load the DLL replincrementlsn
    extended procedure, or one of the DLLs it references. Reason: 126(error not
    found).
    The subscription could not be updated at this time.
    The subscription could not be created.

    Já aconteceu isso com alguém? Podem me ajudar?

    Obrigado


    Alexandre R. Martins
    quarta-feira, 13 de outubro de 2010 14:32

Respostas

  • Pedro, obrigado pela ajuda.

    Mas descobri a resposta em um forum externo, digo em ingles, não sei em que país estava.

    É basicamente assim: quando dá este erro, deve-se reinstalar o sp3 ou sp4 do sql2000, aí passa a funcionar e não dá mais o erro.

    Demorei pra achar a resposta, mas valeu.

    Obrigado a todos e espero ter contribuido de alguma forma.

     


    Alexandre R. Martins
    • Marcado como Resposta Richard Juhasz quarta-feira, 11 de janeiro de 2012 17:26
    quinta-feira, 21 de outubro de 2010 19:16

Todas as Respostas

  • Alexandre,

    Qual foi os nomes que você configurou para suas replicações?

    Você esta utilizando versões diferentes do SQL Server?


    Pedro Antonio Galvão Junior [MVP | Microsoft Evangelist | Microsoft Partner | Engenheiro de Softwares | Especialista em Banco de Dados | SorBR.Net | Professor Universitário | MSIT.com]
    quinta-feira, 14 de outubro de 2010 16:59
    Moderador
  • Pedro, obrigado pela ajuda.

    Mas descobri a resposta em um forum externo, digo em ingles, não sei em que país estava.

    É basicamente assim: quando dá este erro, deve-se reinstalar o sp3 ou sp4 do sql2000, aí passa a funcionar e não dá mais o erro.

    Demorei pra achar a resposta, mas valeu.

    Obrigado a todos e espero ter contribuido de alguma forma.

     


    Alexandre R. Martins
    • Marcado como Resposta Richard Juhasz quarta-feira, 11 de janeiro de 2012 17:26
    quinta-feira, 21 de outubro de 2010 19:16
  • Alexandre,

    Então deve ser aquele erro conhecido existente no SP2 do SQL Server 2000, certo, que bom que resolveu.

    Até mais.


    Pedro Antonio Galvão Junior [MVP | Microsoft Evangelist | Microsoft Partner | Engenheiro de Softwares | Especialista em Banco de Dados | SorBR.Net | Professor Universitário | MSIT.com]
    sexta-feira, 22 de outubro de 2010 10:50
    Moderador