none
EXCEL - AUTOMATIZAR FORMULA NUMA FOLHA A PARTIR DE FOLHAS DIFERENTES RRS feed

  • Pergunta

  • Vou lançar aqui um desafio aos especialistas em excel. Talvez me possam ajudar ou pelo menos evitar que eu perca horas a lançar manualmente uma fórmula:

    Tenho 400 folhas criadas com os seguintes nomes: A1, A2, A3, …..A400.

    Pretendo fazer um resumo numa outra folha e usar a seguinte formula:

    Célula A1 “=SOMA.SE('A1'!$AM$15:$AM$42;H3;'A1'!$Z$15:$AA$42)”

    Célula A2 “=SOMA.SE('A2'!$AM$15:$AM$42;H3;'A2'!$Z$15:$AA$42)”

    Célula A3 “=SOMA.SE('A3'!$AM$15:$AM$42;H3;'A3'!$Z$15:$AA$42)”

    Célula A …….

    Célula A400 “=SOMA.SE('A400'!$AM$15:$AM$42;H3;'A400'!$Z$15:$AA$42)”

    Existe algum procedimento no Excel que permita automatizar sequencialmente esta fórmula, isto é, um procedimento que permita arrastar a fórmula pelas 400 células (A1 A A400) fazendo-a corresponder à folha correta.

    Atentamente,

    Celso Duarte

    quarta-feira, 10 de dezembro de 2014 17:06

Todas as Respostas

  • Olá Celso!

    O intervalo soma na sua fórmula é $Z$15:$AA$42, porém o intervalo real de soma será somente $Z$15:$Z$42, ou seja, só uma coluna, pois o seu intervalo de critério só possui uma coluna também. Se sua intenção é somar as duas colunas baseado no critério aplicado no intervalo AM15:AM42, então você terá que somar duas funções SOMASE. 

    Feitas as considerações, a fórmula em A1 para ser arrastada será:

    =SOMASE(INDIRETO("'A"&LIN(A1)&"'!$AM$15:$AM$42");H4;INDIRETO("'A"&LIN(A1)&"'!$Z$15:$AA$42"))

    Como eu falei acima, se sua intenção é somar o intervalo Z15:AA42, então a fórmula ficará:

    =SOMASE(INDIRETO("'A"&LIN(A1)&"'!$AM$15:$AM$42");H4;INDIRETO("'A"&LIN(A1)&"'!$Z$15:$Z$42"))+SOMASE(INDIRETO("'A"&LIN(A1)&"'!$AM$15:$AM$42");H4;INDIRETO("'A"&LIN(A1)&"'!$AA$15:$AA$42"))

    As fórmulas foram desenvolvidas no Office em português versão brasileira, portanto você deverá observar as alterações necessárias para a versão portuguesa (ex: SOMASE para SOMA.SE).

    Qualquer dúvida pergunte.

    Abraços!


    Rafael Kamimura



    quarta-feira, 10 de dezembro de 2014 22:08