none
cont.se em vba no excel 2003 RRS feed

  • Pergunta

  • boa noite

    Uso a formatação condicional no Excel 2003 para colorir a célula quando encontrar 2 ou mais matricula iguais na coluna A, porém, a planilha fica muito pesada ao usar o procedimento "Private Sub Worksheet_SelectionChange(ByVal Target As Range)"

    Pergunto:

    Como seria o comando em VBA

    =CONT.SE(A:A;A5)>1  a  CONT.SE(A:A;A1500)>1  

    Obrigado.



    • Editado JLNunes terça-feira, 13 de agosto de 2013 23:20
    terça-feira, 13 de agosto de 2013 22:56

Respostas

  • Infelizmente, sua pasta de trabalho também ficará pesada se quiser simular todas as funcionalidades de formatação condicional através do VBA.

    No seu caso, sugiro utilizar a formatação condicional de antes mesmo, mas mudar a forma de se trabalhar na pasta de trabalho para o cálculo manual.


    Felipe Costa Gualberto - http://www.ambienteoffice.com.br

    • Marcado como Resposta JLNunes sexta-feira, 16 de agosto de 2013 00:40
    quinta-feira, 15 de agosto de 2013 23:16
    Moderador

Todas as Respostas

  • Veja um exemplo simples que utiliza o evento Change:

    Private Sub Worksheet_Change(ByVal Target As Range)
        If WorksheetFunction.CountIf(Columns("A:A"), Target) > 1 Then
            Target.Interior.Color = RGB(100, 100, 0)
        Else
            Target.Interior.ColorIndex = -4142
        End If
    End Sub


    Felipe Costa Gualberto - http://www.ambienteoffice.com.br

    terça-feira, 13 de agosto de 2013 23:32
    Moderador
  • bom dia

    no exemplo acima deparei-me com 2 problemas:

    1º o evento cont.se tem que começar apartir da linha 5 ---> CONT.SE(A:A;A5)>1

    2.º ao digitar em A10 = 2030 e em A15 = 2030 as 2 celulas teriam que ficar colorida, porem, a que fica colorida sempre é a segunda, neste caso a celula A15.

    Obrigado.

    quarta-feira, 14 de agosto de 2013 13:27
  • Infelizmente, sua pasta de trabalho também ficará pesada se quiser simular todas as funcionalidades de formatação condicional através do VBA.

    No seu caso, sugiro utilizar a formatação condicional de antes mesmo, mas mudar a forma de se trabalhar na pasta de trabalho para o cálculo manual.


    Felipe Costa Gualberto - http://www.ambienteoffice.com.br

    • Marcado como Resposta JLNunes sexta-feira, 16 de agosto de 2013 00:40
    quinta-feira, 15 de agosto de 2013 23:16
    Moderador