none
Aplicação iniciada via task não mostra Form RRS feed

  • Pergunta

  • Bom dia!

    Tenho uma aplicação Windows Form desenvolvida em C#.net, está funcionando tudo quando executo via VS 2015 ou via duplo clique no executável.

    O problema é que preciso iniciar esta aplicação via Tasks do Windows. Fiz alguns testes, mas sem sucesso. A aplicação inicia, vejo ela executando nos processos do Windows, mas não aparece o formulário.

    Tenho que fazer alguma configuração na aplicação via programação para aparecer o Form?

    Abraços

    PS.: o SO que executa a task é Windows 7 Enterprise 32 bits.

    terça-feira, 15 de dezembro de 2015 13:36

Respostas

  • Pessoal, boa tarde!

    Obrigado pelo apoio de todos.

    Fiz um teste criando uma task para abrir a calculadora nativa do Windows e o comportamento é o mesmo. Ela não abre na tela, mas consigo ver ela nos processos do Windows.

    Partindo deste ponto o problema não esta sendo o meu sistema e sim alguma outra questão. Vou testar em outro ambiente que não tenha tanta política de rede aplicado como onde estou no momento.

    Abraço a todos.

    • Marcado como Resposta Marcos SJ quarta-feira, 16 de dezembro de 2015 19:16
    quarta-feira, 16 de dezembro de 2015 18:24

Todas as Respostas

  • João Antonio Vanelli Ferreira,

    A aplicação fica permanente nos processos?

    Eu encontrei uma thread que parece relatar um problema semelhante se for o caso. Não tenho certeza se é ao menos próximo do que está ocorrendo com a sua aplicação, mas vale a pena dar uma olhada:

    Link

    Espero ter ajudado.

    Atenciosamente


    Marcos Roberto de Souza Junior

    Esse conteúdo e fornecido sem garantias de qualquer tipo, seja expressa ou implícita

    MSDN Community Support

    Por favor, lembre-se de Marcar como Resposta as respostas que resolveram o seu problema. Essa e uma maneira comum de reconhecer aqueles que o ajudaram e fazer com que seja mais fácil para os outros visitantes encontrarem a resolução mais tarde.

    quarta-feira, 16 de dezembro de 2015 10:50
  • Tem algum código? para mostrar ?

    Fulvio C

    quarta-feira, 16 de dezembro de 2015 12:06
  • Olá João Antonio Vanelli Ferreira,

    Dê uma olhada nesta documentação.

    Atenciosamente


    Marcos Roberto de Souza Junior

    Esse conteúdo e fornecido sem garantias de qualquer tipo, seja expressa ou implícita

    MSDN Community Support

    Por favor, lembre-se de Marcar como Resposta as respostas que resolveram o seu problema. Essa e uma maneira comum de reconhecer aqueles que o ajudaram e fazer com que seja mais fácil para os outros visitantes encontrarem a resolução mais tarde.

    quarta-feira, 16 de dezembro de 2015 12:57
  • Bom dia.

    A aplicação está instalada ou tu estás executando da pasta "bin"?

    Qual dos executáveis tu estás tentando abrir?


    Att., Rafael Simor

    quarta-feira, 16 de dezembro de 2015 13:24
  • Pessoal, boa tarde!

    Obrigado pelo apoio de todos.

    Fiz um teste criando uma task para abrir a calculadora nativa do Windows e o comportamento é o mesmo. Ela não abre na tela, mas consigo ver ela nos processos do Windows.

    Partindo deste ponto o problema não esta sendo o meu sistema e sim alguma outra questão. Vou testar em outro ambiente que não tenha tanta política de rede aplicado como onde estou no momento.

    Abraço a todos.

    • Marcado como Resposta Marcos SJ quarta-feira, 16 de dezembro de 2015 19:16
    quarta-feira, 16 de dezembro de 2015 18:24
  • Boa noite

    tô com mesmo problema, vc conseguiu resolver??/

    • Editado Ivan Viana segunda-feira, 22 de janeiro de 2018 06:58
    segunda-feira, 22 de janeiro de 2018 06:25