none
problema RRS feed

  • Pergunta

  • galera estou com esse problema :

    alguem poderia me ajudar e meu  nome de conexão esta correto

    [ArgumentException: The specified named connection is either not found in the configuration, not intended to be used with the EntityClient provider, or not valid.]
       System.Data.EntityClient.EntityConnection.ChangeConnectionString(String newConnectionString) +8425830
       System.Data.EntityClient.EntityConnection..ctor(String connectionString) +43
       System.Data.Objects.ObjectContext.CreateEntityConnection(String connectionString) +85
       LojaVirtual.DAO.LOJAEntities..ctor() in LojaVirtualEDM.Designer.cs:56
       lojaVirtual.WEB.Default..ctor() in Default.aspx.cs:14
       ASP.default_aspx..ctor() +13
       __ASP.FastObjectFactory_app_web_xdavhm5x.Create_ASP_default_aspx() +20
       System.Web.Compilation.BuildResultCompiledType.CreateInstance() +30
       System.Web.Compilation.BuildManager.CreateInstanceFromVirtualPath(VirtualPath virtualPath, Type requiredBaseType, HttpContext context, Boolean allowCrossApp) +100
       System.Web.UI.PageHandlerFactory.GetHandlerHelper(HttpContext context, String requestType, VirtualPath virtualPath, String physicalPath) +31
       System.Web.UI.PageHandlerFactory.GetHandler(HttpContext context, String requestType, String virtualPath, String path) +37
       System.Web.MaterializeHandlerExecutionStep.System.Web.HttpApplication.IExecutionStep.Execute() +346
       System.Web.HttpApplication.ExecuteStep(IExecutionStep step, Boolean& completedSynchronously) +155


    quarta-feira, 13 de julho de 2016 01:11

Respostas

Todas as Respostas

  • >meu  nome de conexão esta correto

    Nao é o que o erro diz. Ele nao encontra a conexao com o nome fornecido.

    Sem ver o codigo e os paramtros de configuraçao, nao vejo como poder te ajudar.

    Se, possivel poste o digo deste construtor:

    lojaVirtual.WEB.Default..ctor() in Default.aspx.cs:14

    Att


    William John Adam Trindade
    Analyste-programmeur
    ----------------------------------------------------------




    quarta-feira, 13 de julho de 2016 15:48
    Moderador
  • Oi willian , 

    o codigo esta assim 

    <configuration>
      <connectionStrings>
         <add name="LOJAEntities" connectionString="metadata=res://*/AdoEDM.csdl|res://*/AdoEDM.ssdl|res://*/AdoEDM.msl;provider=System.Data.SqlClient;provider connection string = Data Source=***********;Initial Catalog=*******;User ID=*********"/>
      </connectionStrings>
      <system.web>
        <customErrors mode="Off"/>
        <compilation targetFramework="4.0">
          <assemblies>
            <add assembly="System.Design, Version=4.0.0.0, Culture=neutral, PublicKeyToken=B03F5F7F11D50A3A"/>
          </assemblies>
        </compilation>
      </system.web>
      <appSettings>

    att

    quarta-feira, 13 de julho de 2016 18:45
  • Ainda nao temos como te ajudar somente com isso.

    Voce verificou se existe o Banco ******* no servidor ***********? 

    Verificou se o usuario ********* tem realmente direito de acesso ao Servidor/Banco: *******/***********?

    A unica coisa que eu posso tre confirmar é que o seu sistema nao consegue acessar o banco fornecido.

    Voce verificou se ele esta aberto para acesso remoto?

    Att


    William John Adam Trindade
    Analyste-programmeur
    ----------------------------------------------------------


    quarta-feira, 13 de julho de 2016 19:17
    Moderador
  • sim willian , meu banco esta criado na locaweb com tabelas , procedures , quando acesso meu banco de dados com IP , servername e senha , conecta normal ate refiz o ADO.net novamente conectando diretamente com os Dados da locaweb e aparece o banco com as tabelas  e meu site esta com conexão com o BD , falei com o pessoal da locaweb , eles fez os teste e me enviou teste bem sucedido. 

    todos os config , esta com a mesma connectiongstring , Web . DAL e Admin

    olha como esta todos .config com o que refiz ADO.net com Dados de conexão sqlserver conctado no servidor da loca web

    <configuration>

    <connectionStrings>

     <add name="LOJAEntities" connectionString="metadata=res://*/AdoEDM.csdl|res://*/AdoEDM.ssdl|res://*/AdoEDM.msl;provider=System.Data.SqlClient;provider connection string=&quot;data source=**********;initial catalog=********;user id=*********;multipleactiveresultsets=True;App=EntityFramework&quot;" providerName="System.Data.EntityClient" />

    </connectionStrings>

    system.web>
        <customErrors mode="Off"/>
        <compilation debug="true" targetFramework="4.0">
          <assemblies>
            <add assembly="System.Design, Version=4.0.0.0, Culture=neutral, PublicKeyToken=B03F5F7F11D50A3A"/>
          </assemblies>
        </compilation>
      </system.web>

    </configuration>

    compilo toda minha app e não da erro 


    • Editado JonatasC quarta-feira, 13 de julho de 2016 23:17 erro
    quarta-feira, 13 de julho de 2016 22:17
  • Jomatas,

    Tenta substituir esse &quote por ' (apostrofo)

    assim:

    <add name="detoxpowerEntities" connectionString="metadata=res://*/AdoEDM.csdl|res://*/AdoEDM.ssdl|res://*/AdoEDM.msl;provider=System.Data.SqlClient;provider connection string='data source=**********;initial catalog=********;user id=*********;multipleactiveresultsets=True;App=EntityFramework'" providerName="System.Data.EntityClient" />


    Att


    William John Adam Trindade
    Analyste-programmeur
    ----------------------------------------------------------

    quarta-feira, 13 de julho de 2016 22:40
    Moderador
  • willian agora aparece esse erro

    Description: An unhandled exception occurred during the execution of the current web request. Please review the stack trace for more information about the error and where it originated in the code. 

    Exception Details: System.ArgumentException: The specified named connection is either not found in the configuration, not intended to be used with the EntityClient provider, or not valid.

    Source Error: 

    [No relevant source lines]

    Source File: App_Web_**********.cs    Line: 

    Stack Trace: 

    [ArgumentException: The specified named connection is either not found in the configuration, not intended to be used with the EntityClient provider, or not valid.]
       System.Data.EntityClient.EntityConnection.ChangeConnectionString(String newConnectionString) +8443431
       System.Data.EntityClient.EntityConnection..ctor(String connectionString) +43
       System.Data.Objects.ObjectContext.CreateEntityConnection(String connectionString) +42

    quarta-feira, 13 de julho de 2016 23:16
  • Adicione este assemblyno web.config:

    <add assembly="System.Data.Entity, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089"/>

    nesta seçao:

     <assemblies>
            <add assembly="System.Design, Version=4.0.0.0, Culture=neutral, PublicKeyToken=B03F5F7F11D50A3A"/>
          </assemblies>


    William John Adam Trindade
    Analyste-programmeur
    ----------------------------------------------------------

    quarta-feira, 13 de julho de 2016 23:35
    Moderador
  • Willian , agora aparece esse erro , 

    porem estou com EDM  DB Local para rodar no localhost nessa aplicação  , vou ter que refazer a EDM  com conexão no SQL com as configuração de dados Locaweb nessa aplicação que estou subindo para servidor locaweb ? porem ja tinha criado o EDM com conexão com o servidor locaweb em  outro backup.

    olha esse erro

    Unable to load the specified metadata resource.

    Description: An unhandled exception occurred during the execution of the current web request. Please review the stack trace for more information about the error and where it originated in the code. 

    Exception Details: System.Data.MetadataException: Unable to load the specified metadata resource.

    Source Error: 
    [No relevant source lines]

    Source File: App_Web_b5d3n54e.4.cs    Line: 

    Stack Trace: 
    [MetadataException: Unable to load the specified metadata resource.]
       System.Data.Metadata.Edm.MetadataArtifactLoaderCompositeResource.LoadResources(String assemblyName, String resourceName, ICollection`1 uriRegistry, MetadataArtifactAssemblyResolver resolver) +2309259
       System.Data.Metadata.Edm.MetadataArtifactLoaderCompositeResource..ctor(String originalPath, String assemblyName, String resourceName, ICollection`1 uriRegistry, MetadataArtifactAssemblyResolver resolver) +32
       System.Data.Metadata.Edm.MetadataArtifactLoaderCompositeResource.CreateResourceLoader(String path, ExtensionCheck extensionCheck, String validExtension, ICollection`1 uriRegistry, MetadataArtifactAssemblyResolver resolver) +8005529
       System.Data.Metadata.Edm.MetadataArtifactLoader.Create(String path, ExtensionCheck extensionCheck, String validExtension, ICollection`1 uriRegistry, MetadataArtifactAssemblyResolver resolver) +64
       System.Data.Metadata.Edm.MetadataCache.SplitPaths(String paths) +307
       System.Data.Common.Utils.<>c__DisplayClass2.<Evaluate>b__0() +18


    quinta-feira, 14 de julho de 2016 00:21
  • Ao publicar deixe 

       <compilation debug="false" targetFramework="4.0">

    Se sua aplicação for Asp.Net MVC verifique ao publicar configurações e certifique-se de ter deixado a pre-compilação habilitada


    Se a resposta contribuiu com seu aprendizado por favor marque como Útil
    Se solucionou seu problema por favor marque como Resposta
    <small>Atenção, se seu problema foi resolvido não deixe o post aberto</small>

    Visite : www.codigoexpresso.com.br
    • Marcado como Resposta JonatasC quinta-feira, 14 de julho de 2016 01:06
    • Não Marcado como Resposta JonatasC quinta-feira, 14 de julho de 2016 01:07
    quinta-feira, 14 de julho de 2016 00:51
  • codigo express , mudei pede para mim voltar para true , 

    marinheiro  de primeira viagem , primeira vez que publico um site 

    isso esta me deixando louco , durmo 4 hrs , as 4 hrs sonho que estou resolvendo o problema , 

    mais obrigado pela colaboração de voce e do willian , gente como vces faz o desenvolvimento  asp.net/C# melhor para mim e entre outro que esta começando com essa linguagem 

    quinta-feira, 14 de julho de 2016 01:14
  • Tentou pre-compilar ao publicar ?


    Se a resposta contribuiu com seu aprendizado por favor marque como Útil
    Se solucionou seu problema por favor marque como Resposta
    <small>Atenção, se seu problema foi resolvido não deixe o post aberto</small>

    Visite : www.codigoexpresso.com.br

    quinta-feira, 14 de julho de 2016 01:23
  • estou trabalhando com VS10  
    quinta-feira, 14 de julho de 2016 01:37
  • Sua aplicação é asp.net  ou asp.net mvc, é uma aplicação ou site ?


    Se a resposta contribuiu com seu aprendizado por favor marque como Útil
    Se solucionou seu problema por favor marque como Resposta
    <small>Atenção, se seu problema foi resolvido não deixe o post aberto</small>

    Visite : www.codigoexpresso.com.br
    quinta-feira, 14 de julho de 2016 01:43
  • asp.net entity , é um site , estou tentando subir para a locaweb e esta o erro ai de cima
    quinta-feira, 14 de julho de 2016 01:48
  • Da uma olhada nesta postagem

    https://social.msdn.microsoft.com/Forums/en-US/cd7e6b1c-7342-4aae-8f07-cdf5bd1ff709/unable-to-load-the-specified-metadata-resource?forum=adodotnetentityframework

    Nesta outra também tem alguma coisa

    http://stackoverflow.com/questions/689355/metadataexception-unable-to-load-the-specified-metadata-resource

    Aparentemente seu problema esta no string de conexão, não gosto do Entity, acabamos por esquecer como usar o banco de dados, prefiro as coisa na unha, ai você sabe exatamente o que esta acontecendo, 

    Nas proximas aulas de meu curso Asp.Net MVC com C# vou começar a trabalhar com banco de dados, tudo na unha, se quiser acompanhar meu curso visite este link 

    http://www.codigoexpresso.com.br/Home/Postagem/32


    Se a resposta contribuiu com seu aprendizado por favor marque como Útil
    Se solucionou seu problema por favor marque como Resposta
    <small>Atenção, se seu problema foi resolvido não deixe o post aberto</small>

    Visite : www.codigoexpresso.com.br
    quinta-feira, 14 de julho de 2016 02:11
  • blz vou ver.

    sim pode contar comigo.

    quinta-feira, 14 de julho de 2016 21:20