none
Duvida para gerar tabela no banco com Code First RRS feed

  • Pergunta

  • Amigos boa tarde!

    Eu criei um model Usuario

    using System;
    using System.Collections.Generic;
    using System.Linq;
    using System.Web;
    
    namespace Buscamisas.Models
    {
        public class Usuario
        {
            public int ID { get; set; }
            public string Nome { get; set; }
            public string CPF { get; set; }
            public string RG { get; set; }
            public System.DateTime DataNascimento { get; set; }
            public bool Sexo { get; set; }
            public string Email { get; set; }
            public string Celular { get; set; }
            public string Telefone { get; set; }
            public System.DateTime DataCriacao { get; set; }
            public System.DateTime DataAlteracao { get; set; }
            public bool Ativo { get; set; }
            public bool Excluido { get; set; }
            public bool Vip { get; set; }
            public string Login { get; set; }
            public string Senha { get; set; }
            public Nullable<System.Guid> GuiID { get; set; }
    
            public bool ReenvioSenha { get; set; }
            public Nullable<int> IDGrupo { get; set; }
            public int QuantiaNovaSenha { get; set; }
            public string TokenAtivacao { get; set; }
    
        }
    }

    Gerei o context

    using System;
    using System.Collections.Generic;
    using System.Linq;
    using System.Web;
    using System.Data.Entity;
    
    namespace Buscamisas.Models
    {
        public class STRING_CONNECTION : DbContext
        {
            public DbSet<Usuario> Usuario { get; set; }
        }
    }

    com o mesmo nome da minha string connection

    <add name="STRING_CONNECTION" connectionString="Data Source=.\SQLEXPRESS;Initial Catalog=Buscamisa;Integrated Security=SSPI" providerName="System.Data.SqlClient" />

    porem quando vou rodar o projeto ele não está criando a tabela no meu banco de dados, será que alguem poderia me auxiliar?

    Obrigado!


    "Nunca deixe que os outros te subestimen, mas tambem não seja arrogante seja humilde e prove quem é

    domingo, 18 de novembro de 2012 16:31

Respostas

  • E ai mano tudo bem?  Bom dia!

    Cara da uma olhada nesse post, ele fala sobre o seu problema e explica:  =D

    http://weblogs.asp.net/scottgu/archive/2010/07/16/code-first-development-with-entity-framework-4.aspx


    quinta-feira, 22 de novembro de 2012 13:15

Todas as Respostas

  • E ai mano tudo bem?  Bom dia!

    Cara da uma olhada nesse post, ele fala sobre o seu problema e explica:  =D

    http://weblogs.asp.net/scottgu/archive/2010/07/16/code-first-development-with-entity-framework-4.aspx


    quinta-feira, 22 de novembro de 2012 13:15
  • Qual o erro que esta retornando?

    Ou ele simplismente não cria?

    quinta-feira, 22 de novembro de 2012 13:23
  • Acabei utilizando o Migration mesmo para subir, eu m pouco mais chatin mais ta valendo...

    VLw a todos


    "Nunca deixe que os outros te subestimen, mas tambem não seja arrogante seja humilde e prove quem é

    quinta-feira, 22 de novembro de 2012 14:33