none
Pede login acessando remoto, localmente funciona RRS feed

  • Pergunta

  • Olá.

    Tenho o RS configurado para o Team Foundation Server. No servidor acessando a url http://meuservidor/Reports/Pages/Folder.aspx é listado normalmente as pastas de relatórios e não pede senha.

    Porém ao acessar a mesma url de fora do servidor mas no mesmo domino, fica pedindo senha e mesmo informando um usuario e senha da rede não consegue acessar a url.

    Alguma dica?

    O serviço do Report está executando com um usuario do dominio com alto privilégio. No Report Manager Tool o mesmo usuário do serviço está configurado para acesar o banco e demais recursos. Localmente tudo funciona. 

    terça-feira, 31 de maio de 2011 13:00

Todas as Respostas

  • Rafael,

     

    Voce adicionou este usuario que voce esta utilizando remotamente para poder visualisar tudo?...

     

    Se seu usuario local for local admin, voce ira ver realmente, porem remotamente nao ira funcionar...


    Oracle OCA11g, MCC 2011! Dicas e novidades: www.fabrizziocaputo.wordpress.com
    terça-feira, 31 de maio de 2011 16:14
    Moderador
  • Sim, por exemplo, acesso WTS no servidor usando MeuDominio\rafael e então abro o IE para ver a pasta do ReportServer e vai na boa.

    Da minha maquina local, tambem no dominio usando MeuDominio\Rafael, abro o IE e tento acessar a pasta e não vai.

    Cheguei a desativar o firewall do servidor para testar e falei com o pessoal de infra, e nada de achar uma pista.

    Detalhe, nunca uso o http://localhost, sempre http://nomedoservidor
    terça-feira, 31 de maio de 2011 17:40
  • Rafael,

    Talvez não seria necessário configurar o IIS para liberar o acesso a este relatório?


    Pedro Antonio Galvão Junior [MVP | Microsoft Evangelist | Microsoft Partner | Engenheiro de Softwares | Especialista em Banco de Dados | SorBR.Net | Professor Universitário | MSIT.com]
    sexta-feira, 3 de junho de 2011 18:59
  • Entendo que a hospedagem não é feita pelo IIS e sim diretamente pelo Report Services.
    sexta-feira, 3 de junho de 2011 23:13
  • Mum,

     

    Quando criado uma instancia SSRS em um servidor, os pool são do IIS, assim como algumas configurações.


    Oracle OCA11g, MCC 2011! Dicas e novidades: www.fabrizziocaputo.wordpress.com
    segunda-feira, 6 de junho de 2011 02:06
    Moderador
  • Fabrizzio,

    Isso mesmo, por isso eu destaquei ao Mum, verificar as configurações do IIS.


    Pedro Antonio Galvão Junior [MVP | Microsoft Evangelist | Microsoft Partner | Engenheiro de Softwares | Especialista em Banco de Dados | SorBR.Net | Professor Universitário | MSIT.com]
    quarta-feira, 8 de junho de 2011 18:00
  • Boa Noite,

    Primeiro adicione o site à lista de sites confiáveis. Caso isso não seja suficiente veja os passos abaixo:

    O browser utilizado foi o Internet Explorer ? Se sim, tente os seguintes passos:

    - Tools, Internet Options
    - Supondo que seja uma Intranet, selecione Local Intranet e clique em Custom Level
    - No final (User Autentication), certifique-se de escolher uma opção que não seja Anonymous Logon (sugiro Automatic Logon only in Intranet Zone)

    [ ]s,

    Gustavo Maia Aguiar
    http://gustavomaiaaguiar.wordpress.com


    Classifique as respostas. O seu feedback é imprescindível
    quarta-feira, 8 de junho de 2011 22:23
  • Maia,

    Cara bem lembrado, existem algumas configurações no IE para autenticação anônima, eu sinceramente não me lembrava.


    Pedro Antonio Galvão Junior [MVP | Microsoft Evangelist | Microsoft Partner | Engenheiro de Softwares | Especialista em Banco de Dados | SorBR.Net | Professor Universitário | MSIT.com]
    quarta-feira, 15 de junho de 2011 00:20