locked
Como faço para comparar dois valores e retornar outro ? RRS feed

  • Pergunta

  • Olá amigos,

    Estou precisando de uma grande ajuda, preciso que o excel compare duas celulas com valores diferentes e retorne em outra celula o valor que quero.

    ex.: A2 = Retorno (retornos vão de R0, R1, R2, R3, R4, R5, R6, R7, R8)
           A3 = Meses (vão de 3, 6, 9, 12, 15, 18, 24, 30, 36)
           A4 = Coeficiente ( cada mes tem um coeficiente corespondente aos "R's" e meses).

    Gostaria que quando eu selecionasse o retorno R0 e o Mes 3 ou qualquer outro retornasse o coeficiente que esta correspondendo ao mes 3 e ao R0 na célula  A4 de coeficiente.)

    Espero ter explicado .

    http://www.entranet.com.br/excel/exemplo.xls

    qualquer duvida segue o exemplo para melhor entender.

     

    quarta-feira, 24 de janeiro de 2007 15:42

Respostas

  • Boa tarde,

    Na planilha de exemplo citada, insira, na célula $D$8, a seguinte fórmula:

    =SE(OU(ÉCÉL.VAZIA($C$2);ÉCÉL.VAZIA($D$2));NÃO.DISP();ÍNDICE($G$6:$O$14;CORRESP($D$2;$F$6:$F$14;0);CORRESP($C$2;$G$3:$O$3;0))) ENTER

    Observe que a fórmula acima foi desenvolvida com base nos intervalos do seu exemplo, em http://www.entranet.com.br/excel/exemplo.xls.

    Atenciosamente,

    quarta-feira, 24 de janeiro de 2007 17:20

Todas as Respostas

  • Boa tarde,

    Na planilha de exemplo citada, insira, na célula $D$8, a seguinte fórmula:

    =SE(OU(ÉCÉL.VAZIA($C$2);ÉCÉL.VAZIA($D$2));NÃO.DISP();ÍNDICE($G$6:$O$14;CORRESP($D$2;$F$6:$F$14;0);CORRESP($C$2;$G$3:$O$3;0))) ENTER

    Observe que a fórmula acima foi desenvolvida com base nos intervalos do seu exemplo, em http://www.entranet.com.br/excel/exemplo.xls.

    Atenciosamente,

    quarta-feira, 24 de janeiro de 2007 17:20
  • Otávio,

    Muito obrigado, funcionou perfeitamente, não entendi como funciona as condiçoes que você usou mas funcionou uma blz, agradeço por sua ajuda .

    Muito agradecido mesmo,

    Abraços.

     

    quarta-feira, 24 de janeiro de 2007 18:34