none
Erro em pagina, servidor não encontra DLL! RRS feed

  • Pergunta

  • Aplicação não encontra a dl negocio que esta na pasta bin.

    Não encontra a dll do projeto negocio, mas a dll esta na pasta bin.

    Ja coloquei tds os tipos de arquivos na pasta bin, mas ele não reconhece. O que pode ser?

    sexta-feira, 29 de abril de 2016 14:23

Respostas

  • Paulinha,

    Foi feito a publicação completa da aplicação ou só atualizou alguns arquivos?


    Carlos Eduardo Ferreira

    • Marcado como Resposta Marcos SJ segunda-feira, 2 de maio de 2016 14:09
    sexta-feira, 29 de abril de 2016 19:56

Todas as Respostas

  • Você adicionou a referência no projeto? 
    Clique com o direito em "References", "Add Reference..." e adicione a referência desejada. Se for um projeto (ClassLibrary) na mesma "Solution" selecione a opção "Solution" senão você vai selecionar "Browse".

    Att,


    Se a resposta contribuiu com seu aprendizado por favor marque como util, se solucionou seu problema marque como resposta.

    sexta-feira, 29 de abril de 2016 14:49
  • Sim, isso já foi feito.

    Local funciona normal, mas quando eu publico da este erro!

    sexta-feira, 29 de abril de 2016 15:00
  • Bom dia

    Paula, vai em "References"  clique com o direito na referência "Negocio" vai em propriedades. Em "Copy Local" selecione "True".

    att,


    Se a resposta contribuiu com seu aprendizado por favor marque como util, se solucionou seu problema marque como resposta.

    sexta-feira, 29 de abril de 2016 15:03
  • Acebei de ver isso e ja esta true!
    sexta-feira, 29 de abril de 2016 15:20
  • É uma "ClassLibrary" no projeto ou "dll" externa?

    Att,


    Se a resposta contribuiu com seu aprendizado por favor marque como util, se solucionou seu problema marque como resposta.

    sexta-feira, 29 de abril de 2016 15:25
  • É uma dll externa.
    sexta-feira, 29 de abril de 2016 15:34
  • Boa tarde,

    Paula, a versões do Framework são as mesmas (projeto e Negocios.dll)?

    Eu tive esse mesmo problema mas resolvi com "Copy Local".

    Att,


    Se a resposta contribuiu com seu aprendizado por favor marque como util, se solucionou seu problema marque como resposta.

    sexta-feira, 29 de abril de 2016 16:56
  • Pior que são!

    São projetos diferentes dentro da mesmo Solution.

    Não tenho nem ideia no que mexer, pode ser alguma configuração no servidor?

    sexta-feira, 29 de abril de 2016 17:09
  • Verifica se te ajuda:
    http://forums.iis.net/t/1207523.aspx?Compiler+Error+Message+CS0246+The+type+or+namespace+name+IHSHeaderFunctions+could+not+be+found+are+you+missing+a+using+directive+or+an+assembly+reference+

    Att,


    Se a resposta contribuiu com seu aprendizado por favor marque como util, se solucionou seu problema marque como resposta.

    sexta-feira, 29 de abril de 2016 17:21
  • Pior que está td certo e o erro continua.

    Mas obrigada mesmo assim Silvaney!!
    sexta-feira, 29 de abril de 2016 19:06
  • Paulinha,

    Foi feito a publicação completa da aplicação ou só atualizou alguns arquivos?


    Carlos Eduardo Ferreira

    • Marcado como Resposta Marcos SJ segunda-feira, 2 de maio de 2016 14:09
    sexta-feira, 29 de abril de 2016 19:56
  • Bom dia,

    Por falta de retorno, esta thread será encerrada.

    Caso seja necessário, por gentileza, abra uma nova thread.

    Atenciosamente


    Marcos SJ

    Esse conteúdo e fornecido sem garantias de qualquer tipo, seja expressa ou implícita

    MSDN Community Support

    Por favor, lembre-se de Marcar como Resposta as postagens que resolveram o seu problema. Essa é uma maneira comum de reconhecer aqueles que o ajudaram e fazer com que seja mais fácil para os outros visitantes encontrarem a resolução mais tarde.

    segunda-feira, 2 de maio de 2016 14:09