locked
Contar vazio com criterios RRS feed

  • Pergunta

  • Ola,

    Preciso de ajuda,

    Não estou conseguindo lançar uma formula no excel com criterios de verificação de data, situação(a situação sao varias se for uma delas ele ja tem que contar), e se for um tipo de regional.

    exemplo: na coluna c podera ser varias se for uma dessas ja tem que contar.(Designado ou Em Processo ou Aguardando cliente)

     coluna r  a data esta com formato : [$-409]mmmm d, aaaa hh:mm AM/PM;@ - exibe January 11, 2011 12:00 AM. onde deverá verificar somente o mes e ano...qualquer data dentro do mes....

    e na coluna S se tiver vazio....

    quinta-feira, 13 de janeiro de 2011 14:33

Todas as Respostas

  • Tita,

    Está confuso. Vc menciona contar vazio com critérios no título e estou imaginando que vc quer contar os eventos onde (referência linha2 da planilha):

    1 - C2="Designado" OU C2="Em Processo" OU C2="Aguardando cliente"

    E

    2 - R2=1    (HIPÓTESE minha, de que vc busca os registros de JANEIRO)

    E

    3 - S2=""  (registro na Coluna S for vazio)

    FAÇA em T2, por exemplo ---> =SE(E(OU(C2="Designado";C2="Em Processo";C2="Aguardando cliente");MÊS(R2)=1;S2="");1;0) e ARRASTE para baixo.

    Qualquer resultado=1 significa que as 3 condições foram atendidas. Em T1 faça =SOMA(T2:T100). Esta soma seria o CONT.SE() com mais de um critério.

    Se não for isso poste a planilha e explique mais detidamente seu problema.


    Abs,


    quinta-feira, 13 de janeiro de 2011 21:09
  • Mandrix, eu fiz este mais retornou 0 e deveria ser um em uma das linhas.

    Na minha palnilha pelo menos nao funcionou...mais fiz uma outra que é para auxiliar no calculo e deu certo...mais ela nao ve o mes somente uma data fixa ...se puder me ajudar?....ela deverá ver o mes inteiro...e outra...ele ve somente um tipo...mais ja ajuda...pq ja criei uma auxiliar....e coloco cada um tipo separado e depois somo..sem problemas....mais claro se mudar isso pra mim ja vai ser o maximoo...

     

    =CONT.SES('Chamados Adm.Pessoal 2011'!$R$2:$R$15833; DATA(2011;1;11);'Chamados Adm.Pessoal 2011'!$C$2:$C$15833;"Designado";'Chamados Adm.Pessoal 2011'!$O$2:$O$15833;"CO / N")

    sexta-feira, 14 de janeiro de 2011 16:37
  • Mandrix, eu fiz este mais retornou 0 e deveria ser um em uma das linhas.

    Na minha palnilha pelo menos nao funcionou...mais fiz uma outra que é para auxiliar no calculo e deu certo...

    Afinal... Deu certo ou não deu certo?

    Faz melhor, posta a planilha que ajudamos.

    Abs,

     

    domingo, 16 de janeiro de 2011 07:34
  • A planilha tem mais de 5 mb... e nao estou conseguindo posa-la..manda seu email.

    tambem preciso contar com intervalo de datas de abertura com fechamento..ou seja nao somente se a coluna s vazia mais tambem se preenchida com data X.

    segunda-feira, 17 de janeiro de 2011 15:54
  • Você já tentou com o SOMARPRODUTO?

    De uma olhadinha em 

    http://www.officevb.com/2010/12/respondendo-perguntas-com-o-excel.html

    Teste ai e qqer coisa fale.

    Att


    Bruno Silva Leite
    officevb.com
    segunda-feira, 17 de janeiro de 2011 21:07