none
Session active - Numeros errados RRS feed

  • Pergunta

  • Pessoal,

    No perfomon , contadores de asp.net application, session active, está ocorrendo algo muito estranho.
    Ao visualizar o número de sessões ativas por aplicação, aparecem poucas sessões, certinho porém no totalizador aparece bilhares...

    Em outros momentos, algumas aplicações indicam bilhares de variáveis ativas mas no total aparece algo como 500, 600 ou algo próximo a isso, ou seja, o negócio está completamente louco.

    A poucos minutos atrás estava com pouco mais de 1000 sessões e de um segundo para o outro pulou para bilhares de sessões ativas sem que houvesse crescimento de acessos.

    O que pode estar ocorrendo ?

    segunda-feira, 22 de outubro de 2012 19:36

Todas as Respostas

  • Rafael, nunca tive este tipo de problema, mas este artigo da Microsoft pode nos dar um norte para a solução. 

    http://support.microsoft.com/kb/969722


    Washington Luíz | MCP, MCTS
    O Senhor é minha força e somente Nele confio.

    segunda-feira, 22 de outubro de 2012 19:45
  • Washington, 

    Apesar de nunca ter instalo o 3.5 e o problema ter ocorrido do nada, acho que tem sentido este service pack pois o valor que exibe é bem semelhante ao valor relatado no site : 

    > Por exemplo, o valor exibido é 4294967267. ( retirado do site ) 

    Vou tentar instalar este service pack ( medooooooooo.. todo SP da microsoft vem com uma supresa )

    Vamos ver o que dá.. Obrigado pela ajuda !

    segunda-feira, 22 de outubro de 2012 21:52
  • Olá Rafael. Depois informe se o problema foi resolvido. Caso não tenha sido, vamos ver se encontramos mais informações.

    Abraços.


    Washington Luíz | MCP, MCTS
    O Senhor é minha força e somente Nele confio.

    terça-feira, 23 de outubro de 2012 11:52
  • Washington,

    instalei o SP mas nada mudou... reinicie o ISS e depois de algumas horas subiu novamente para 4 bilhões de sessões exatamente como mostrado acima.

    :(

    terça-feira, 23 de outubro de 2012 14:58
  • Bom, vou olhar com alguns amigos que tenho que trabalham com Infra para ver se algum deles já passou por isso.

    Abraços.


    Washington Luíz | MCP, MCTS
    O Senhor é minha força e somente Nele confio.

    terça-feira, 23 de outubro de 2012 15:43
  • Amigo,

    Esse valor não poderia ser em bytes não?
    Não acho difícil que seja isso...que o valor que está sendo exibido seja o valor da seção na memória e não o valor de seções ativas.


    Não esqueça de marcar como útil uma resposta que te ajude.
    "A diversão é a alma do negócio"


    • Editado Lucas Vandor terça-feira, 23 de outubro de 2012 17:14
    terça-feira, 23 de outubro de 2012 17:14
  • Lucas,

    o valor é o número de sessões ativas mesmo e roda certinho por algumas horas e depois dá esta bagunçada.

    Abraços

    quarta-feira, 24 de outubro de 2012 02:02