none
Formatação integer workflow CRM 4.0 RRS feed

  • Pergunta

  • Depois da migração os problemas multiplicam-se, agora detectei outro não se alguém me pode ajudar.

    Tinha um workflow que na entidade conta atribuia autmaticamente o accountnumber, accontece que o qworkflow funciona mas quando insere o inteiro na base de dados insere com pontos, por exemplo o nº 55555 insere 55.555

    Alguém já lhe aconteceu algo parecido?

    Saudações


    Hélder Oliveira
    terça-feira, 17 de maio de 2011 11:25

Respostas

  • Pelo que vi no SDK de ambas versões o campo não mudou de tipo, continua sendo um nvarchar de 20, o workflow que está falando não é padrão, é customizado feito em c#/vb.net certo? Se for pode ser que algo tenha mudado no objeto/classe. Consulte o sdk da versão 4 e compare.

     

    Att,

    Tiago Cardoso

    terça-feira, 17 de maio de 2011 15:25
    Moderador
  • Tiago, 

    tem razão é um workflow desenvolvido em c#, já tinha efectuado alguns testes o numeo saia da dll correctamente o problema está na formatação do integer, penso eu.

     

    No entanto para resolver o problema, em vez do workflow retornar um interiro puz a retornar uma string e problema foi resolvido.

     

    Obrigado!

    Saudações


    Hélder Oliveira
    • Marcado como Resposta HM Oliveira terça-feira, 17 de maio de 2011 16:47
    terça-feira, 17 de maio de 2011 16:41

Todas as Respostas

  • Pelo que vi no SDK de ambas versões o campo não mudou de tipo, continua sendo um nvarchar de 20, o workflow que está falando não é padrão, é customizado feito em c#/vb.net certo? Se for pode ser que algo tenha mudado no objeto/classe. Consulte o sdk da versão 4 e compare.

     

    Att,

    Tiago Cardoso

    terça-feira, 17 de maio de 2011 15:25
    Moderador
  • Tiago, 

    tem razão é um workflow desenvolvido em c#, já tinha efectuado alguns testes o numeo saia da dll correctamente o problema está na formatação do integer, penso eu.

     

    No entanto para resolver o problema, em vez do workflow retornar um interiro puz a retornar uma string e problema foi resolvido.

     

    Obrigado!

    Saudações


    Hélder Oliveira
    • Marcado como Resposta HM Oliveira terça-feira, 17 de maio de 2011 16:47
    terça-feira, 17 de maio de 2011 16:41
  • Ótimo, marque como resposta por favor.

     

    []'s,

    Tiago Cardoso

    terça-feira, 17 de maio de 2011 16:42
    Moderador