none
Bloquear dados duplicados EXCEL RRS feed

  • Pergunta

  • Bom dia, estou com essa planilha em anexo, o que acontece é o seguinte:

    O usuario seleciona o codigo do produto, e por consequência o material é preenchido através de procv, até aí tudo ok, meu problema é na parte do lote, cada material pode ter até 40 lotes e eles não podem se repetir dento do mesmo material, por exemplo o código 80178.100 começa no lote 1 e vai até o 40, e eles não se repetem, o código 80189.000 também vai do 1 ao 40, ou sejo preciso de uma formula que não deixem os codigos se repetirem dentro do mesmo material. 

     

    atenciosamente

     

    André

    segunda-feira, 26 de novembro de 2018 18:28

Todas as Respostas

  • André,

    Minha sugestão é transportar estes dados para microsoft access, assim vc poderá registros únicos, através chaves primarias / estrangeiras .

    sexta-feira, 30 de novembro de 2018 17:09
  • Boa tarde,

    Você pode utilizar a opção validação de dados na guia Dados do Excel no grupo Ferramentas de dados.

    Utilize a opção Persoanlizado da regras e ajuste a função conforme a regra que precisa.

    Selecione a coluna A inteira e selecione o recurso validação de dados

    Eu considerei que na coluna A não poderia permitir digitar valor repetido:

    =CONT.SE($A:$A;A1)<2

    Caso nunca tenha usado a validação de dados, neste vídeo apresentamos o recurso:

    https://youtu.be/XT3QopLP824

    Espero que ajude, me informe o feedback do seu projeto,

    Abraços,

    Paulo

    • Editado Paulo Tácio quarta-feira, 29 de maio de 2019 19:10
    quarta-feira, 29 de maio de 2019 18:59