locked
INDICE/CORRESP OU VLOOKUP COM CRITÉRIO ENTRE DATAS RRS feed

  • Pergunta

  • Boa tarde,

    Estou precisando resolver a seguinte questão:

    Tenho um arquivo no link (http://groups.google.com.br/group/orprs-excel-vba/web/MULTIPLA_BUSCA.xls) que preciso fazer uma procura e retornar um resultado.

    O critério de busca é que uma determinada data parametrizada esteja compreendida entre outras duas datas.

    Por exemplo, a data procurada é 16/1/2008. Esta data está entre as datas 31/12/2007 e 27/1/2008 (que são as colunas Data Início e Data Fim). Então o valor retornado será o da coluna D (Data 21), que é 21/1/2008.

    Criando um teste de mesa, eu consigo fazer (como mostra a tabela F1:N13). Porém, preciso fazer isso numa fórmula só (que seria a célula D22).

    Alguém possui uma solução para isso?

    Agradecido.
    quarta-feira, 16 de janeiro de 2008 14:26

Respostas

  • Para célula D21 uma opção é usar:

    =SOMARPRODUTO(1*(DESLOC(LISTA_CICLOS;0;1)<D18);1*(DESLOC(LISTA_CICLOS;0;2)>=D18);1*(LISTA_CICLOS))

    Qq dúvida, é só postar novamente.

     

    quinta-feira, 17 de janeiro de 2008 09:31

Todas as Respostas

  • Para célula D21 uma opção é usar:

    =SOMARPRODUTO(1*(DESLOC(LISTA_CICLOS;0;1)<D18);1*(DESLOC(LISTA_CICLOS;0;2)>=D18);1*(LISTA_CICLOS))

    Qq dúvida, é só postar novamente.

     

    quinta-feira, 17 de janeiro de 2008 09:31
  • Adilson, está perfeito.

    Muito obrigado.

    []s
    quinta-feira, 17 de janeiro de 2008 11:34