none
Liberar download do .config RRS feed

  • Pergunta

  • Pessoal,

    nao sei se esse eh o local mais adequado pra postar isso, mas la vai...

    tenho arquivos .config para a configuracao de um aplicativo, esses arquvios serao baixados da internet... a questao eh que o IIS 7, por questao de seguranca, bloqueia download de arquivos .config... quero saber como liberar o download desses .config no meu site ?

    Obrigado

    Luiz
    sexta-feira, 20 de março de 2009 15:25

Respostas

Todas as Respostas

  • Tentando ajudar...

    Não sei se é exatamente isso mas, eu sei que no IIS existe uma configuração quando você clica em propriedades em um site/diretório virtual que você consegue, de acordo com a extensão do arquivo, executar ou não determinado tratamento.

    Por padrão, o .config é mapeado para o aspnet_isapi.dll. Talvez se você remover esta entrada, esta extensão pare de ser "monitorada" pelo asp.net e ele deixe você baixar isso sem problemas.

    Para fazer isso, dentro de propriedades na aba Virtual Directory lá embaixo existe os Application settings. Clique no botão Configuration. Na proxima telinha que abre você pode fazer as modificações.

    Eu já tive uma situação onde o usuário não poderia baixar o pdf diretamente. Portanto, eu fiz com que o aspnet também "monitorasse" a extensão .pdf

    []'s

    Valdek Santos Santana Junior.
    sexta-feira, 20 de março de 2009 18:33
  • Valdek,

    obrigado pela resposta...

    eu ja tinha realmente lido algo sobre isso, acredito que essa seja a solucao... a questao eh que no IIS 6 isso pode ser feito, ja no IIS 7, os menus sao diferentes... no IIS 7 acredito que essa parte seja o "Mapeamento de Manipulador", mas nessa area a extensao .config ja nao aparece por default... ja tentei configurar algumas coisas nessa area mas nenhuma resolveu...

    Luiz
    sexta-feira, 20 de março de 2009 19:41
  • bom...

    fucando mais um pouco encontrei o seguinte...

    http://support.microsoft.com/kb/942045/

    resolve o problema... pra quem precisar...

    Luiz
    sexta-feira, 20 de março de 2009 20:50