none
problemas com configuração do Emulador Pocket PC 2003 + WEBSERVICE RRS feed

  • Pergunta

  • Olá pessoal,

    Estou precisando de ajuda com a configuração do meu emulador "Emulador Pocket PC 2003 " que está dispponível no VS 2008 PRO.

    O problema é o seguinte:

    Tenho um Webservice instalado no IIS do endereço IP 192.168.1.2(minha maquina). Quando entro no IE ele funciona normalmente pela maquina.

    Ja procurei em todo o forum sobre configurações de internet e rede local para emulador pocket e não achei nada que funcionasse.

    So para detalhar, minha applicação pocket PC utiliza o seguinte endereço: http://192.168.1.2/WSGV/ServicoGV.asmx. Ao rodar o projeto, é assinalada em verde a linha  

    Dim


    Analista Programador .Net www.fabner.com.br
    results() As Object = Me.Invoke("CarregaFuncionarios", New Object(-1) {})

    É exibido um erro de acesso, pois o pocket não consegue encontrar o endereço do web service.

    Alguem póderia me ajudar com esta configuração de pocket?


    Obrigado
    • Editado FPimenta quarta-feira, 6 de maio de 2009 19:51 erro do forum
    quarta-feira, 6 de maio de 2009 19:49

Respostas

  • Olha, vc precisa ter o active sync 4.5 instalado no desktop. 

    - La no VS , em "Tools", tem o "Device Emulator Manager". 
     *Vc abre ele e escolhe o emulador que vc está utilizando.
     *O emulador deve esta conectado. 
     *Ai vc seleciona o seu emulador na lista e acessa o menu "Action" do "Device Emulator Manager", depois clica em    "Cradle". Isto vai linkar o seu emulador com o desktop atravez do Active Sync.
     *O icone do Active Sync perto do relogio no desktop, deve ficar verde e indicar que esta conectado com um   dispositivo. 
     *Talvez ainda seje necessário configurar o Active Sync ( Configurações de Conexão).
    O meu ta marcado o seguinte:   

    - Permitir Conexões USB
    - Permitir Conexões com um dos seguintes Itens ( DMA )
      - Este computador esá conectado a ( internet )

    Acho que isso é o essencial


    Att

    Miguel Faria


    • Marcado como Resposta FPimenta segunda-feira, 18 de maio de 2009 15:46
    sexta-feira, 15 de maio de 2009 19:53
  • Ola pessoa,

    Desculpem pela demora em responder. Estou envolvido em um projeto e to sem mesmo.

    Descobri qual era o meu erro.

    eu acabei selecionando o adaptador NE2000 quando na verdade eu deveria deixa-lo descmarcado.

    ai funcionou. Claro que tive que habilitar o tipo de conexao DMA no meu active Sync.

    Obrigado a todos

    Abraço
    Analista Programador .Net www.fabner.com.br
    • Marcado como Resposta FPimenta segunda-feira, 18 de maio de 2009 15:46
    segunda-feira, 18 de maio de 2009 15:45

Todas as Respostas

  • Fabner,

    Veja se o firewall do seu micro está permitindo acesso HTTP. Verifica também no emulator se consegue acessar o webservice pelo Internet Explorer.

    []s,
    Carlos dos Santos - cdssoftware.spaces.live.com
    quarta-feira, 6 de maio de 2009 20:58
  • Carlos,

    Estou utilizando o Windows Firewall e o acesso HTTP esta liberado sem problemas. Quanto ao emulador, não consigo acesar o webservice pelo IE.

    Poderia explicar como seria uma configuração ideal para que eu possa tentar aqui?

    Obrigado

    Abraço
    Analista Programador .Net www.fabner.com.br
    quinta-feira, 7 de maio de 2009 01:47
  • Fabner,

    No emulador entre em File\Configure\Network, habilite "Enable NE2000 PCMCIA network adapter and bind to:" e selecione sua placa de rede. Normalmente ele exigirá que seja instalado o Virtual PC 2007, para permitir compartilhar a internet com o emulador.
    No Windows Mobile, clique em Start\Settings\Connections\Tasks\Select Networks, em "Network Management" altere "Programs that automatically connect to the Internet shoud connect using" para "My Work Network", em seguida clique em "Edit", vá a aba "Proxy Settings" habilite "This network connects to internet".
    Feito isto acesse algum site pelo IE do Windows Mobile.

    Outra forma seria adicionar uma nova rede: http://msdn.microsoft.com/pt-br/library/bb158505.aspx


    Paulo R. Pereira - Obs.: Se a resposta foi útil não se esqueça de marcar. Obrigado!
    quinta-feira, 7 de maio de 2009 11:50
  • Ola Paulo,

    Obrigado pela atenção.

    Fiz a configuração do jeito que você indicou mas ainda não consegui uitlizar a internet.  No debug do projeto continuo recebendo a mensagem "could not establish connection to network" no momento que o projeto vai chamar o webservice que está instalado nesta mesma maquina.

    Não sei se essa informação ajuda mas, estou utilizando o Emulador Pocket PC 2003 Second Edition. Com relação a TCP/IP é necessário se configurar algo?

    Tem algo mais que posso tentar?

    Grato


    Fabner
    Analista Programador .Net www.fabner.com.br
    • Editado FPimenta quinta-feira, 7 de maio de 2009 14:09 perguntas adicionais
    quinta-feira, 7 de maio de 2009 14:03
  • Fabner,

    SE vocë tiver DHCP na rede n"ao precisa, caso contrario tem que abrir as configuracoes de rede e colocar o IP manualmente no emulador.

    Va em Start/Settings/connections/network cards
    clica no NE2000 e configura o IP.

    Att.


    Carlos dos Santos - cdssoftware.spaces.live.com
    quinta-feira, 7 de maio de 2009 21:14
  • Quanto a configuração do ip ele consegue pegar sozinho. no meu caso está como 192.168.1.5

    Mas ainda continua o problema

    obrigado
    Analista Programador .Net www.fabner.com.br
    quinta-feira, 7 de maio de 2009 21:50
  • Olha, vc precisa ter o active sync 4.5 instalado no desktop. 

    - La no VS , em "Tools", tem o "Device Emulator Manager". 
     *Vc abre ele e escolhe o emulador que vc está utilizando.
     *O emulador deve esta conectado. 
     *Ai vc seleciona o seu emulador na lista e acessa o menu "Action" do "Device Emulator Manager", depois clica em    "Cradle". Isto vai linkar o seu emulador com o desktop atravez do Active Sync.
     *O icone do Active Sync perto do relogio no desktop, deve ficar verde e indicar que esta conectado com um   dispositivo. 
     *Talvez ainda seje necessário configurar o Active Sync ( Configurações de Conexão).
    O meu ta marcado o seguinte:   

    - Permitir Conexões USB
    - Permitir Conexões com um dos seguintes Itens ( DMA )
      - Este computador esá conectado a ( internet )

    Acho que isso é o essencial


    Att

    Miguel Faria


    • Marcado como Resposta FPimenta segunda-feira, 18 de maio de 2009 15:46
    sexta-feira, 15 de maio de 2009 19:53
  • Ola pessoa,

    Desculpem pela demora em responder. Estou envolvido em um projeto e to sem mesmo.

    Descobri qual era o meu erro.

    eu acabei selecionando o adaptador NE2000 quando na verdade eu deveria deixa-lo descmarcado.

    ai funcionou. Claro que tive que habilitar o tipo de conexao DMA no meu active Sync.

    Obrigado a todos

    Abraço
    Analista Programador .Net www.fabner.com.br
    • Marcado como Resposta FPimenta segunda-feira, 18 de maio de 2009 15:46
    segunda-feira, 18 de maio de 2009 15:45