none
Web.Config Transform não funciona Visual Studio 2010 RRS feed

  • Pergunta

  • Amigos,

    Não estou conseguindo configurar o web.config transform. Crio dentro da solução no Configuration Manager a minha nova opção de configuração normalmente, sendo que para ela aparecer tive que desmarcar a opção "Create new project configuration", caso contrario a configuração criada não aparecia e nenhuma msg de erro.

    Feito isso, ao clicar com o botão direito no Web.Config não aparece no sub-menu a opção Add Config Transforms.

    Pesquisando, vi em um forum para editar o arquivo .project, que no meu caso não existe, visto que é um projeto web. Então editei o arquivo da solution adicionando a tag TransformWebConfigEnabled = "true" para o projeto web, porém não surtiu efeito.

    Ainda em outro forum em tools->Options->Projects and Solutions ativar a opção "Show advanced build configurations", no caso já estava ativada.

    Versão utilizada Vs 2010 Ultimate 10.040219.1 SP1 Rel, cópia é registrada e utilizamos o TFS.


    Renato Mattos

    terça-feira, 4 de dezembro de 2012 22:10

Respostas

  • Bom, funciona somente em projetos Web Application e não em projetos WebSite pelo que parece, visto que adicionei a solução apenas para teste um projeto Web Application e a opção Add Config Transforms apareceu. Bom mais uma pernada do VS, afinal se fosse facil já estaria em casa..rs

    Renato Mattos

    • Marcado como Resposta Renato Mattos quarta-feira, 5 de dezembro de 2012 17:37
    terça-feira, 4 de dezembro de 2012 22:59