none
Problema com permissão de usuários para o acesso do conteúdo do report server RRS feed

  • Pergunta

  • Boa tarde, tenho o report server intalado em minha máquina, uso autenticação por formulários, porém quando entro e registro um usuário este usuário fica sem permssão para entrar no gerenciador ou no servidor de relatórios, como faço para alterar as permissões destes usuários? o erro que recebo quando logo é o seguinte:

    Talvez seja algo simples de resolver, mais como sou leigo no assunto ainda não encontrei a solução, desde já agradeço a compreensão de todos!
    Att Alisson R. S. Haubert

    quarta-feira, 20 de março de 2013 18:30

Todas as Respostas

  • alissonhaubert, boa noite.

    No caso vc já foi em configurações de pasta? Se sim você consegue visualizar os usuários ou grupos de usuários que você adicionou?

    Caso você consiga visualizar, você tera de editar o grupo ou usuário para aplicar a permissão de visualizão de relatórios.

    Agora se nada disso acontecer, você precisa ter os usuários no AD do seu servidor e assim adicionar um a um no reporting services.

    Espero ter ajudado.

    Att.

    Chilipi_10

    quarta-feira, 20 de março de 2013 21:33
  • Não tenho acesso as configurações de pasta pois não consigo acessar o gerenciador, acho que deveria ter feito esta configuração antes de ter feito as alterações para o modo de autenticação por formulários, mesmo com o usuário administrador do sistema não consigo acesso, dá o mesmo erro, vou tentar restaurar os arquivos de configuração padrão do report server.
    alguma outra sugestão?

    quinta-feira, 21 de março de 2013 17:57
  • Alisson,

    Fora do gerenciador do Reporting Services, via Windows Explorer você não consegui acessar as propriedades da Pasta?


    Pedro Antonio Galvão Junior [MVP | Microsoft Evangelist | Microsoft Partner | Engenheiro de Softwares | Especialista em Banco de Dados | SorBR.Net | Professor Universitário | MSIT.com]

    segunda-feira, 25 de março de 2013 18:41
  • Bom dia, desculpa a pergunta besta, mais a qual pasta? hehe
    terça-feira, 26 de março de 2013 11:32
  • Alisson,

    Estou me referindo a pasta que se encontra os arquivos dos seus relatórios.


    Pedro Antonio Galvão Junior [MVP | Microsoft Evangelist | Microsoft Partner | Engenheiro de Softwares | Especialista em Banco de Dados | SorBR.Net | Professor Universitário | MSIT.com]

    quinta-feira, 28 de março de 2013 18:04
  • Alisson,

    Você pode dar essa permissão incluindo o usuário nas configurações de segurança da página inicial do gerenciador de relatórios.

    Tenta ir até a página inicial e clica em configurações de pasta, lá atribui uma função ao usuário. (logado como administrador)

    Obs.: Você vai precisar de permissões de administrador para realizar esse procedimento.


    Se esta sugestão for útil, por favor, classifique-a como útil. Se ela lhe ajudar a resolver o problema, por favor, marque-a como Resposta.

    quinta-feira, 4 de abril de 2013 13:15
  • Alisson,

    Você consegui acessar: http://localhost/Reports/



    Pedro Antonio Galvão Junior [MVP | Microsoft Evangelist | Microsoft Partner | Engenheiro de Softwares | Especialista em Banco de Dados | SorBR.Net | Professor Universitário | MSIT.com]

    quinta-feira, 4 de abril de 2013 17:58
  • Alisson,

    A resposta pra seu problema é simples mesmo, passei por essa semana um caso parecido com o seu, vou relatar o que fiz:

    Fui add um usuário para poder vizualizar os relatórios criados para ele, pedi ao pessoal de infra-suporte que criassem esse usuário para mim, o usuário foi criado, adicionei o usuário exemplo: "dominio.nomeusuario" até ai funcionou, porém deu a mesma tela de erro que apareceu pra vcquando fui logar com o usuário criado, ai questionei o pessoal de infra-suporte se tinha alguma permissão no AD, ai me responderão que não, no caso entrei com meu usuário de administrador novamente e com isso percebi que a pasta raiz precisava adicionar o usuário e ai quando fiz isso funcionou \o/.

    Pagina inicial é nessa pagina que chamo de pasta raiz é la que deve constar a permissão de usuário.

    Espero que também de certo para você abraços!

    Att.: Chilipi_10


    • Editado chilipi_10 sábado, 6 de abril de 2013 17:24 falta de letras
    sábado, 6 de abril de 2013 17:23
  • no meu caso a solução chegou até a ser engraçada, sofri tanto e o que eu tinha feito de errado era que eu tinha criado um usuário com username: admin e uma senha qualquer, depois de sofrer tanto descobri que se eu criasse o usuário com username e senha admin tudo estava resolvido, porém estou com um outro problema agora, estou tendo falta de permissão do usuário do sql server na hora de renderizar o relatório, me é retornada a mensagem abaixo:

    Já verifiquei tudo e não consigo identificar onde está o problema o datasource está apontado certo para a base de dados e o usuário aparentemente tem permissões para acessar essa base, não sei o que está acontecendo, alguém já teve um problema parecido ou sabe a possível causa para este problema?

    Att.
    Alisson R. S. Haubert

    quarta-feira, 10 de abril de 2013 18:02
  • Alisson,

    Você fez o teste no seu SSRS? Se você fez o teste com o mesmo usuário e senha e funcionou, você precisar verificar na pasta de conexões se está certo os dados, caso não funcione dentro do seu SSRS, terá de verificar o usuário na base de dados.

    Espero ter ajudado.

    Att.:

    Chilipi_10

    sexta-feira, 12 de abril de 2013 21:26
  • descobri o que acontecia, coisa bem simples, o sql estava configurado para aceitar autenticação do windows somente, foi só habilitar para a autenticação do sql também que funcionou normalmente.
    segunda-feira, 15 de abril de 2013 11:39