none
Problema para Replicacao RRS feed

  • Pergunta

  • Fui tentar replicar um SQL Server e, reclamou do nome desse server. Usei o comando abaixo para verificar o nome correto:

    Select @@ServerName

    Na Replicacao da a seguinte critica:

    TITLE: New Publication Wizard
    ------------------------------

    SQL Server is unable to connect to server 'IP,Porta'.

    For help, click: http://go.microsoft.com/fwlink?ProdName=Microsoft%20SQL%20Server&ProdVer=12.0.2000.8&EvtSrc=Microsoft.SqlServer.Management.UI.PubWizardErrorSR&EvtID=CantConnect&LinkId=20476

    ------------------------------
    ADDITIONAL INFORMATION:

    SQL Server replication requires the actual server name to make a connection to the server. Specify the actual server name, 'TRTSRV023\DIALER'. (Replication.Utilities)

    ------------------------------

    Na hora de conectar no SSMS, aparece IP,Porta e nao essa nomenclatura.

    Pesquisei e vi que esse seria o problema.

    Duvida:

    eu posso mudar o nome para o IP e Porta, sem impactos ou se mudar ferra tudo?

    mudar que eu digo seria:

    sp_dropserver <old_name>;  
    GO  
    sp_addserver <new_name>, local;  
    GO

    Ou como seria o correto a fazer?

    Sera necessario verificar todas as aplicacoes que utilizam e setar o novo nome, outras coisas mais complexas ou mudar o nome e dar andamento a Replicacao?

    Muito obrigado a todos desde ja.

    Abs,

    Ricardo

    segunda-feira, 16 de outubro de 2017 16:51

Respostas

  • Na teoria não tem nada pra dar erro.

    Se vc não tiver um ambiente de desenvolvimento ou homologação, instale uma instância local na sua máquina sem a replicação e depois a adicione como vc deve fazer em produção.

    Acho que precisa reiniciar o serviço do Agent.

    Abs


    Vinicius Fonseca - MCP | MCTS | MCDBA | MCITP | MCTS | MCT | ITIL Foundation - DGA SISTEMAS - Se minha resposta for útil, classifique-a. :)

    terça-feira, 17 de outubro de 2017 17:13

Todas as Respostas

  • Na hora de conectar pelo SSMS no nome do servidor informe o nome  TRTSRV023\DIALER.  Para configurar a replicação o SQL Server exige que a conexão seja feito pelo  nome do servidor.

    Att. Leandro Bugalho


    segunda-feira, 16 de outubro de 2017 18:05
  • Muito obrigado pelo retorno Leandro.

    Eu tentei, mas nao reconhece..da erro..seria caso de falar com alguem de infra (algum acesso no server) ou eu mesmo para resolver?

    Tentativa como voce falou e, que eu ja tinha tentado:

    TITLE: Connect to Server
    ------------------------------

    Cannot connect to TRTSRV023\DIALER.

    ------------------------------
    ADDITIONAL INFORMATION:

    Erro de rede ou específico à instância ao estabelecer conexão com o SQL Server. O servidor não foi encontrado ou não estava acessível. Verifique se o nome da instância está correto e se o SQL Server está configurado para permitir conexões remotas. (provider: SQL Network Interfaces, error: 26 - Erro ao Localizar Servidor/Instância Especificada) (Microsoft SQL Server, Error: -1)

    For help, click: http://go.microsoft.com/fwlink?ProdName=Microsoft%20SQL%20Server&EvtSrc=MSSQLServer&EvtID=-1&LinkId=20476

    Abs,

    Ricardo

    segunda-feira, 16 de outubro de 2017 18:14
  • Sua maquina tem que resolver o nome TRTSRV023 .  Deve  haver algum problema de dns já que você consegue acessar a instância via IP.  

    Att. Leandro Bugalho

    segunda-feira, 16 de outubro de 2017 18:18
  • Obrigado novamente pela resposta, Leandro.

    Eu estou na minha estacao e conectando o servidor pelo SSMS, entao pedi acesso ao ambiente de instalacao mesmo, via TS e fui criar por la, aparentemente daria certo, pois nao apareceu mais o mesmo erro, mas esse SQL nao esta configurado para replicacao, entao terei que fazer o processo como se fosse instalar e, flagar os componentes de conectividade, para dar andamento.

    Farei apos as 19h hoje, qualquer outro problema, duvida ou eu conseguindo, posto aqui novamente.

    Mais uma vez obrigado.

    Abs,

    Ricardo Bezerra

    segunda-feira, 16 de outubro de 2017 18:55
  • Ola, boa noite a todos!

    Alguem saberia confirmar se seria esse o procedimento mesmo?

    La no Servidor do SQL, usar o Setup de instalacao --> Installation --> New SQL stand-alone...add features --> next..next..next... mantendo todas as mesmas configuracoes e flagar a opcao de Replicacao e continuar para instalar?

    Sendo isso em producao e, com o banco startado?

    Se alguem puder ajudar, agradeco muito.

    Abs,

    Ricardo

    segunda-feira, 16 de outubro de 2017 22:36
  • Ola, boa noite a todos!

    Alguem saberia confirmar se seria esse o procedimento mesmo?

    La no Servidor do SQL, usar o Setup de instalacao --> Installation --> New SQL stand-alone...add features --> next..next..next... mantendo todas as mesmas configuracoes e flagar a opcao de Replicacao e continuar para instalar?

    Sendo isso em producao e, com o banco startado?

    Se alguem puder ajudar, agradeco muito.

    Abs,

    Ricardo

    Bom dia!

    Seguindo esse procedimento:

    https://technet.microsoft.com/en-us/library/ms172376(v=sql.105).aspx

    terça-feira, 17 de outubro de 2017 11:27
  • Ninguem pode ajudar-me pessoal, por favor.
    terça-feira, 17 de outubro de 2017 14:36
  • Olá.

    Vc ja tem a feature da replicação instalada? Senão, ja tentou instalar pelo centro de instalação na opção "new installation or add features to ... " ?

    Ou vc já está tentando configurar a replicação entre os dois bancos?



    Vinicius Fonseca - MCP | MCTS | MCDBA | MCITP | MCTS | MCT | ITIL Foundation - DGA SISTEMAS - Se minha resposta for útil, classifique-a. :)


    terça-feira, 17 de outubro de 2017 15:06
  • Obrigado pela resposta.

    Eu na vdd nao tenho o servidor com a opcao de replicacao flagada.

    Sei pq fui refazendo o processo de "instalacao" ate chegar na parte de opcoes do que eu quero instalar...a flag de replicacao nao estava marcada.

    Por tratar-se de producao e o BD estar no ar, nao quis flagar e continuar o processo ate o final...

    No link que passei mais acima, nao fala nada sobre precisar parar banco e/ou restartar..mesmo assim, nao quis arriscar sem ter certeza. Por isso abri esse post.

    Bom, em resumo: eu fui criar uma replica e disse que o nome do server estava errado, ai abri esse post, mas parei pra pensar e, estava acessando o server da minha estacao, via SSMS, entao fiz acesso TS no server do SQL mesmo e o erro do nome nao apareceu, mas disse que nao tinha instalado o que precisava para replicar...fui atras e achei o link que comentei que eu passei...ai achei o setup e fui refazer o processo, so que so a primeira opcao do 'install'..cheguei no ponto de flagar o que queria instalar e vi la a opcao de replica sem flag..

    Gostaria de uma ajuda...se eu flagar e mandar bala ate o fim..vai dar certo ou vai dar problema?

    Abs,

    Ricardo

    terça-feira, 17 de outubro de 2017 15:55
  • Na teoria não tem nada pra dar erro.

    Se vc não tiver um ambiente de desenvolvimento ou homologação, instale uma instância local na sua máquina sem a replicação e depois a adicione como vc deve fazer em produção.

    Acho que precisa reiniciar o serviço do Agent.

    Abs


    Vinicius Fonseca - MCP | MCTS | MCDBA | MCITP | MCTS | MCT | ITIL Foundation - DGA SISTEMAS - Se minha resposta for útil, classifique-a. :)

    terça-feira, 17 de outubro de 2017 17:13
  • Valeu, vou testar hoje a noite dessa forma...primeiro install sem replica local e depois refazer habilitando a replica e ver no que da...boa...

    Abs

    terça-feira, 17 de outubro de 2017 17:32
  • Boa tarde, Ricardo.Bezerra.

    Conseguiu o que precisava?

    Filipe B de Castro

    Esse conteúdo é fornecido sem garantias de qualquer tipo, seja expressa ou implícita

    MSDN Community Support

    Por favor, lembre-se de Marcar como Resposta as postagens que resolveram o seu problema. Essa é uma maneira comum de reconhecer aqueles que o ajudaram e fazer com que seja mais fácil para os outros visitantes encontrarem a resolução mais tarde.

    sexta-feira, 20 de outubro de 2017 19:01
    Moderador
  • Boa tarde,

    Por falta de retorno essa thread está encerrada.

    Se necessário, favor abrir uma nova thread.

    Atenciosamente,


    Filipe B de Castro

    Esse conteúdo é fornecido sem garantias de qualquer tipo, seja expressa ou implícita

    MSDN Community Support

    Por favor, lembre-se de Marcar como Resposta as postagens que resolveram o seu problema. Essa é uma maneira comum de reconhecer aqueles que o ajudaram e fazer com que seja mais fácil para os outros visitantes encontrarem a resolução mais tarde.

    segunda-feira, 23 de outubro de 2017 17:22
    Moderador
  • Desculpe, consegui sim.

    Sera preciso instalar as features e habilitar para poder fazer replicacao (flagar para permitir replicas) e continuar com o precesso, como se fosse uma instalacao do SQl mesmo.

    So que optando apenas para instalar features.

    A correria nao me permitiu voltar aqui e, ate me fez abrir novos posts antes de finalizar esse.

    Desculpe mais uma vez.

    Obrigado.

    Ricardo

    sexta-feira, 3 de novembro de 2017 14:00
  • Desculpe, consegui sim.

    Sera preciso instalar as features e habilitar para poder fazer replicacao (flagar para permitir replicas) e continuar com o precesso, como se fosse uma instalacao do SQl mesmo.

    So que optando apenas para instalar features.

    A correria nao me permitiu voltar aqui e, ate me fez abrir novos posts antes de finalizar esse.

    Desculpe mais uma vez.

    Obrigado.

    Ricardo

    Ah, precisei fazer esse procedimento diretamente la no server onde o SQL esta instalado.
    sexta-feira, 3 de novembro de 2017 14:01