locked
EXTRAIR INFORMAÇÕES DE BANCO DE DADOS NO EXCEL RRS feed

  • Pergunta

  • Ola pessoal, preciso da ajuda de vocês!
    Tenho um banco de dados de preços no excel com as seguintes colunas:
    FAMILIA DE PROD PRODUTO   MARCA    LOJA        PREÇO
    Café                     café 250g      x           super         5,00
    Café                     afé 500g       y           hiper          4,00
    Café                     café 250g      x           bom preço 3,00
    Cappuccino           pote 200g       x          super         8,00
    Cappuccino           pote 100g       y          market       7,00
    Solúvel                 sache 50g      x           bom preço  2,20
    Solúvel                 sache 50g      x           hiper           2,10

    Por exemplo, eu gostaria de saber quantas familia de produtos café, da marca X aparecem no banco de dados na loja super? Quantos Cappuccino, da marca y aparecem no banco de dados da marca Y na loja market?
    Estou tendo dificuldades pois os critérios para a busca são vários.

    obrigado!
    quinta-feira, 17 de dezembro de 2009 00:08

Respostas

  • Boa noite,
    A título de exemplo vamos colocar o seguinte conteúdo nas células
    G1 >> FAMILIA DE PRODUTO
    G2 >> MARCA
    G3 >> LOJA
    G5 >> CONTAGEM

    H1 >> Café
    H2 >> X
    H3 >> Super
    H5 >> =SOMARPRODUTO(($A$2:$A$8=H1)*($C$2:$C$8=H2)*($D$2:$D$8=H3))

    Outras pesquisas podem ser feitas alterando os parâmetros de busca ou acrescentando outros seguindo a lógica da função SOMARPRODUTO.

    Mais informações sobre contagens e somas condicionais em: http://adilsonsoledade.blogspot.com/2009/11/uma-das-duvidas-mais-frequentes-que.html

    [ ]s

    Adilson Soledade - MOS http://adilsonsoledade.blogspot.com/
    • Sugerido como Resposta adilsonsoledade quinta-feira, 17 de dezembro de 2009 00:54
    • Marcado como Resposta diogoska sexta-feira, 18 de dezembro de 2009 00:43
    quinta-feira, 17 de dezembro de 2009 00:54