none
ABRIR PAGINAS HTTP EM UM IFRME RRS feed

  • Pergunta

  • Olá Pessoal, estou com um problema que é o seguinte:

    Em determinado momento dentro de uma entidade, terá que aparecer uma página web dentro de um IFRAME no CRM.

    Só que este IFRAME so esta permintindo que eu abra protocolos HTTPS, e paginas http não abrem  automaticamente.

    Apenas o Internet Explorer fornece a opção pertuntando se eu quero ou nao mostrar o conteudo do IFrame, alguem sabe o que devo fazer?

    (mando em anexo a imagem do que eu consigo fazer, os numeros: representam o acontecimento)

    1- Aviso que so aparece no Internet explorer.

    2- IFRAME onde se abre a pagina que eu quero (no caso uma pagina http qualquer), so é aberta essa pagina assim que eu clico em "Mostrar Conteudo". E eu gostaria de abrir de qualquer forma independente de configuração de navegador.

    A linha vermelha na diagonal separa um ação acontecida antes de aparecer a pag. no IFRAME

    sexta-feira, 10 de outubro de 2014 18:44

Respostas

  • Boas Wagner,

    Para começar o screenshot é muito bonito principalmente o site que estás a tentar abrir :D

    Infelizmente não sei se tenho boas notícias penso que estás a tentar abrir uma página HTTP (não segura) dentro de uma página segura (HTTPS) por isso está a bloquear é um comportamento relativamente recente. O teu CRM é um ambiente on-premise? Se for pode ser que tenhamos sorte, temos é que realizar o nosso próprio SSL. Outra solução pode passar por tentar fazer load do HTML dentro de um Recurso Web. Esclarece-me apenas se tens controlo sobre o servidor do CRM e se consegues fazer algumas experiências lá. Já agora o setting para que ele não bloqueie tem a ver com o Mixed Content.

    Espero ter ajudado.
    Se respondi a sua pergunta por favor marque como resposta e\ou como útil.


    Pedro Azevedo Crm Specialist 4.0\2011

    segunda-feira, 13 de outubro de 2014 13:30

Todas as Respostas

  • Boas Wagner,

    Para começar o screenshot é muito bonito principalmente o site que estás a tentar abrir :D

    Infelizmente não sei se tenho boas notícias penso que estás a tentar abrir uma página HTTP (não segura) dentro de uma página segura (HTTPS) por isso está a bloquear é um comportamento relativamente recente. O teu CRM é um ambiente on-premise? Se for pode ser que tenhamos sorte, temos é que realizar o nosso próprio SSL. Outra solução pode passar por tentar fazer load do HTML dentro de um Recurso Web. Esclarece-me apenas se tens controlo sobre o servidor do CRM e se consegues fazer algumas experiências lá. Já agora o setting para que ele não bloqueie tem a ver com o Mixed Content.

    Espero ter ajudado.
    Se respondi a sua pergunta por favor marque como resposta e\ou como útil.


    Pedro Azevedo Crm Specialist 4.0\2011

    segunda-feira, 13 de outubro de 2014 13:30
  • Boas Azevedo,

    O ambiente que estou trabalhando é on-premise, mas não tenho controle sobre o servidor CRM(por questões de segurança minha equipe não tem acesso a base do cliente). 

    Por acaso você teria exemlos dos itens que você mencionou?

    "temos é que realizar o nosso próprio SSL"

    "tentar fazer load do HTML dentro de um Recurso Web"

    Cada dia que passa aparece alguma coisa nova pra eu aprender, dai acabo ficando perdido com tanta informação, que nem consigo procurar as vezes. Rs

    quarta-feira, 15 de outubro de 2014 14:18
  • Boas Wagner,

    Olha em relação ao "próprio SSL" no fundo é tu teres um roteador e que em vez de chamares o site diretamente chamares uma aplicação tua que seja https e que consiga mostrar a página de destino. Infelizmente neste momento não tenho grande tempo para fazer isso mas mal tenha posso tentar fazer. A solução de obter a página HTTP e mostrar dentro de um Recurso Web falhou, pois estou a mesma a fazer uma requisição a um site http e também não dá.

    Outra solução é pedires ao IT que habilite a opção de mostrar "conteúdo misturado" (mixed content). No firefox e chrome para além da interface gráfica podes ir pelos settings para ele fazer isso sempre, no firefox escreve no URL about:config e colocas a false a seguinte chave security.mixed_content.block_active_content no chrome corres o seguinte comando --allow-running-insecure-content, aqui tens como correr comandos no chrome. No IE podes modificar um setting.

    Espero ter ajudado.
    Se respondi a sua pergunta por favor marque como resposta e\ou como útil.


    Pedro Azevedo Crm Specialist 4.0\2011

    • Sugerido como Resposta Azevedo PedroMVP quarta-feira, 22 de outubro de 2014 14:51
    quarta-feira, 22 de outubro de 2014 14:51