none
Não consigo instalar o Template (.Net Framework 3.0) no IDE do Visual Studio RRS feed

  • Pergunta

  • Olá, boa noite a todos!

    Estou com um problemão, ja instalei, desinstalei, instalei denovo e nada de aparecer o template (.Net Framework 3.0) no IDE do meu Visual Studio.

    Instalei o Microsoft Windows Software Developer Kit for .Net 3.0;
    Depois o .Net Framework 3.0, depois Visual Studio Orcas de Março de 2007, e não aparece o template.

    Ja fiz isso no Windows XP Professional SP2, e no Windows Vista Ultimate e nada.

     

    Ja instalei somente o .Net 3.0 e o Microsoft Windows Software Developer Kit for .Net 3.0, sem instalar o Orcas onde teoricamente deveria aparecer o template no VS 2005, e nada.

     

    O mais intrigante, é que em linha de comando funciona. Se eu construo uma app XAML em linha de comando no BRAÇO com bloco de notas e compilo funciona. Mas no Visual Studio nada.

    Funciona também no mesmo equipamento o Expression Blend.

    Peço que por gentileza, quem possa ter algum tipo de informação que possa me ajudar a fazer aparecer esse bendito TEMPLATE, que possa estar respondendo a essa questão.

     

    Obrigado!

     

    José Eustáquio Santana - Téu - Cianorte-PR

    quarta-feira, 28 de março de 2007 01:37

Respostas

Todas as Respostas

  • O Visual Studio Orcas será a nova versão do Visual Studio... A versão CTP de Março já possui tudo que você precisa pra desenvolver com .Net Framework 3.0 (inclusive 3.5)...

    Se você estiver querendo desenvolver com o Visual Studio 2005, está faltando você instalar as extensões do Visual Studio 2005 para WPF e WCF, que está disponível aqui: http://www.microsoft.com/downloads/details.aspx?familyid=F54F5537-CC86-4BF5-AE44-F5A1E805680D&displaylang=en

    quarta-feira, 28 de março de 2007 12:15
    Moderador
  • José.

     

    Só para garantir... no Orcas March-CTP não há nomenclatura ".Net Framework 3.0" no diálogo "New Project"; por exemplo: para criar uma aplicação WPF o caminho é (C#):

     

    Visual C# -> Windows -> WPF Application

     

    Importante: Há no canto superior-direito do diálogo um dropdown que filtra os templates para framework 2, 3 e 3,5.

     

    Abraço.

    quarta-feira, 28 de março de 2007 13:06
  • Olá,

     

    Ai está outro problema, eu baixei e tento instalar o Extensions, mas diz que :

     

    "Setup has detected a prerequisite is missing. To use Visual Studio 2005 extensions for .Net Framework 3.0 (WCF, WPF) November 2006 CTP you must have the .Net Framework 3.0 runtime instaled. Please install the .Net Framework 3.0 runtime and restart setup."

     

    Mas ja instalei o .net 3.0, e mesmo assim ele fica dando que não está instalado, ja fiz isso no Windows XP e no Windows Vista, usando o Visual Studio 2005 e Visual Studio Orcas também.

     

    No Vista por exemplo que já vem com o .Net 3.0, instalei o SDK : Microsoft Windows Software Developer Kit for .Net 3.0

    Depois instalei o VS Orcas, e nada.

    Depois instalei o SDK: Microsoft Windows Software Developer Kit for .Net 3.0 e Visual Studio 2005 e nada tbm

     

    Cheguei até a formatar o Hd e Reinstalar o Windows XP, sozinho e instalar o .Net 3.0, SDK : Microsoft Windows Software Developer Kit for .Net 3.0, Visual Studio Orcas

    e BUMMMM nada tbm de aparecer os templates.

     

    CURIOSIDADE: se faço o aplicativo em linha de comando funciona. Tipo fiz um tutorial de XAML pela linha de comando e bloco de notas, e compilei em linha de comando e funciona normal.

    Então na verdade eu creio que o .Net 3.0 está instalado, senão nao funcionaria em linha de comando.

     

    Mas os templates no VS não aparecem.

     

    A outra mensagem que o colega tbm passou de não ser mais (.NET FRAMEWORK 3.0) os templates mas ... New Project, Visual Basic /C#, Windows, WPF Application, também não aparece.

    Também não tem nenhum drop down que filtre os templates no meu IDE. Tanto do Vs 2005 como do Vs Orcas 2007.

     

    Não sei mais o que fazer.

    Obrigado pela ajuda até aqui, mas não consegui ainda.

     

    José Eustáquio Santana - Téu

    Destéu Informática e Sistemas Ltda

    Cianorte-PR

    quarta-feira, 28 de março de 2007 13:59
  • José.

     

    1) O que você chama Orcas é o CTP de Março que têm 4 GB?

    2) Você está utilizando os instaladores finais do .Net 3, de novembro (Fx 21/nov, sdk 7/nov, extensions 6/nov) ?

     

    quarta-feira, 28 de março de 2007 20:44
  • Vitor.

     

    O Orcas é sim o Visual Studio Codename 'ORCAS' de Março que tem 4.33GBs!

    o .Net framework que estou instalando é o que vem no DVD dele, é instalado juntamente com ele o (.Net 3.0 e 3.5 beether) e o 2.0SP1

    o Extensions eu não consigo instalar, ele diz que está dando uma mensagem de erro:

     

    Setup has detected a prerequisite is missing. To use Visual Studio 2005 extensions for .Net Framework 3.0 (WCF, WPF) November 2006 CTP you must have the .Net Framework 3.0 runtime instaled. Please install the .Net Framework 3.0 runtime and restart setup

     

    Já instalei esse bendito .Net 3.0 runtime and componentes, que é o que vem junto no DVD do VS março!

     

    A não ser que tem outro .Net framework mais antigo que ele esteja querendo que eu instale.

     

    Vc tem os links exatos do que precisa ser instado?!

     

    Eu não sei mais o que fazer. Como já disse, até instalar somente o Windows XP, e instalar o .Net 3.0, o SDK de Março e o Visual Studio Orcas de Março eu fiz. Ficou so isso instalado no Windows, e mesmo assim não funcionou.

     

    Agradeço mais uma vez, espero que cheguemos num ponto frutuoso

     

    []s.

     

    Téu - José Eustáquio Santana

    Destéu Informática e Sistemas Ltda

    Cianorte-PR

    quarta-feira, 28 de março de 2007 21:14
  • José.

     

    Realmente... você está fazendo tudo certo... o que certamente eu te recomendaria seria formatar mas você disse que já o fez...

     

    Não precisa instalar o SDK porque o Orcas de março traz o MSDN atualizado...

     

    Se a única limitação for os templates eu posso te enviá-los...


     

    Aqui tem os últimos releases:

     

    http://msdn2.microsoft.com/en-us/windowsvista/aa904955.aspx?wt.svl=DwnldWVdwnld

     

    Abraço

     

    Vítor

     

     

    PS: este editor estragou meu dia... mais uma vez!

    quinta-feira, 29 de março de 2007 14:26
  • José.

     

    Verifique se existem os seguintes arquivos:

     

    VS2005:  %ProgramFiles\Microsoft Visual Studio 8\Common7\IDE\ProjectTemplatesCache\CSharp\NET Framework 3.0\WinFXApplication.zip

     

    Orcas: %ProgramFiles\Microsoft Visual Studio 9.0\Common7\IDE\ProjectTemplatesCache\CSharp\Windows\1033\WPFApplication.zip

     

    Se existirem entre no PROMPT DO VISUAL STUDIO *RESPECTIVO* e digite devenv /InstallVSTemplates

     

    Com o Visual Studio fechado.

     

    Abraço.

    quinta-feira, 29 de março de 2007 17:33
  • Olá Vitor, tudo bem!

    Essa madrugada por volta de 02:30, eu consegui, finalmente.

     

    Encontrei um outro link para um .Net Framework 3.0 de 3mg que executa a instalacao e vai baixando e instalando, de novembro de 2006 e o Visual Studio Extensions tbm de Nov 2006. Que por alegria quase geral, fez aparecer os Templates .Net Framework 3.0 no Visual Studio 2005. Mas no Vs Orcas até agora nada mesmo.

    Consegui fazer algumas coisinhas no Vs 2005 com os templates WinFXApplication

     

    Mas quanto a questão dos templates:

    VS2005:  %ProgramFiles\Microsoft Visual Studio 8\Common7\IDE\ProjectTemplatesCache\CSharp\NET Framework 3.0\WinFXApplication.zip

     

    Orcas: %ProgramFiles\Microsoft Visual Studio 9.0\Common7\IDE\ProjectTemplatesCache\CSharp\Windows\1033\WPFApplication.zip

     

    só encontrei mesmo os do Visual Studio 2005, mas não preciso executar mais o Devenv... porque ja estão aparecendo.

     

    Agora no Orcas nao encontrei o WPFApplication.zip.

     

    Com isso estou com o template somente no VS 2005.

     

    Será que se vc conseguir para mim esses templates e me enviar por email, por exemplo, e eu executando  InstallVsTemplates poderá funcionar?

     

    Se vc puder, eu posso estar passando o meu email e vc me enviando isso.

     

    Do mais, muito obrigado pela atenção.

     

     

    José Eustáquio Santana - Téu

    Destéu Informática e Sistemas Ltda

    Cianorte-PR

     

    quinta-feira, 29 de março de 2007 17:54
  • Vitor.

     

    Se você puder me enviar os templates, vamos fazer mais esse teste, vamos instalar eles no Visual Studio Orcas e ver o que dá né.

     

    Adiciona o meu MSN ai e trocamos o email para envio:

     

    teu_70@hotmail.com

     

     

    José Eustáquio Santana - Téu

    Destéu Informática e Sistemas Ltda

    Cianorte-PR

    quinta-feira, 29 de março de 2007 18:43
  •  Vítor wrote:

    José.

     

    Realmente... você está fazendo tudo certo... o que certamente eu te recomendaria seria formatar mas você disse que já o fez...

     

    Não precisa instalar o SDK porque o Orcas de março traz o MSDN atualizado...

     

    Se a única limitação for os templates eu posso te enviá-los...


     

    Aqui tem os últimos releases:

     

    http://msdn2.microsoft.com/en-us/windowsvista/aa904955.aspx?wt.svl=DwnldWVdwnld

     

    Abraço

     

    Vítor

     

     

    PS: este editor estragou meu dia... mais uma vez!

    quinta-feira, 29 de março de 2007 18:45
  • José.

     

    Enviei para o teu e-mail.

    quinta-feira, 29 de março de 2007 19:52
  • Eu instalei o C# Orcas ontem (26/04/07) em duas máquinas (uma Vista e uma XP) em ambas aparecem os templates para aplicação WPF mas se tento criar a aplicação ele exibe o erro "The project type is not supported by this instalation" e não cria a nova aplicação.. nas duas máquinas o problema é identico. Ja aplicações Windows forms ele cria sem problemas.. mas acho q naum vai ser agora que vou começar a estudar WPF... a menos que alguem conheça a solução, alguem??

    quinta-feira, 26 de abril de 2007 16:22
  • Estou com o mesmo problema que voce, eu instalei

      net 3

      vista sdk    feb 2007

      mas o vs para  sdk não instala dando a mesma mensagem.

     

     

    Qual é este link que voce encontrou que possui o net e o vs extensions ?

     

    Muito obrigado desde ja !!!!

     

    sábado, 15 de setembro de 2007 01:48
  • Voce só vai conseguir instalar depois que atualizar o seu VS2005 para o sp1. Sem o service pack 1 não instala mesmo

     

    []'s

    Sanses

     

    terça-feira, 11 de dezembro de 2007 06:46